summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/binutils/APKBUILD12
-rw-r--r--system/binutils/disable-ifunc-tests.patch12
-rw-r--r--system/binutils/fix-plt-main-bnd-test.patch11
3 files changed, 18 insertions, 17 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index bc6528c70..5fa5c7d6e 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
-pkgver=2.29
-pkgrel=2
+pkgver=2.30
+pkgrel=0
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
@@ -15,11 +15,11 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
[ "${CARCH}" != "mips" ] && subpackages="$subpackages $pkgname-gold"
# non-PIC is unsupported by musl/ppc
[ "${CARCH}" == "ppc" ] && options='!check'
-source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
+source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
binutils-ld-fix-static-linking.patch
disable-gnu-mbind.patch
+ disable-ifunc-tests.patch
disable-preinit-array-tests.patch
- fix-plt-main-bnd-test.patch
mips-illegal-memcpy.patch
remove-no-static-plt-test.patch
remove-pr2404-tests.patch
@@ -128,11 +128,11 @@ gold() {
mv "$pkgdir"/usr/$CTARGET/bin/ld.gold "$subpkgdir"/usr/$CTARGET/bin/ld.gold
}
-sha512sums="8148587d7e4f14ebcbcb3f984b116deaae5d4008228628acde14bc242a64a4b53faf1f6077a2c4ca4750e2f254b698ba506bd657f79e1202e87e7029b0069337 binutils-2.29.tar.bz2
+sha512sums="e747ea20d8d79fcd21b9d9f6695059caa7189d60f19256da398e34b789fea9a133c32b192e9693b5828d27683739b0198431bf8b3e39fb3b04884cf89d9aa839 binutils-2.30.tar.xz
ecee33b0e435aa704af1c334e560f201638ff79e199aa11ed78a72f7c9b46f85fbb227af5748e735fd681d1965fcc42ac81b0c8824e540430ce0c706c81e8b49 binutils-ld-fix-static-linking.patch
d378fdf1964f8f2bd0b1e62827ac5884bdf943aa435ec89c29fc84bb045d406b733fffaff8fdd8bd1cba8ddea7701c4cf6ccf3ed76a8a3df9c72b447737575a6 disable-gnu-mbind.patch
+ba2b5c8cdfa95db7a1f05da8a2c1ffc3bcb35300abf7061e52249d9b29037e3fdef1aed830686bca2df74b9f5d48684e9c8e2f49715455bf90dca6e3bfc077eb disable-ifunc-tests.patch
3537752e63cef0b5ef136d003ff7e814ba66b12624d817430112d0f291a792e8960fa69a78036f526af835441b3ee483d6a53d55c7b3dd8ee96f0399682dbcbe disable-preinit-array-tests.patch
-01149e3b772c92783048cc65a4fe6d63770c9f8351ff087901679ba886ccad0bdaeec83033be4537651570de0b042f2cb8e2fad0bcab70afae773053dfda11be fix-plt-main-bnd-test.patch
06422157349abf02e79a5ef8bd9f51100e7e996aab65250d518e0cf0d7ac8ed922d3bf1603c4f5b4fd8fb179266b7b4c41db32dcb241d60a7f1c21d1df0c36dd mips-illegal-memcpy.patch
b40f9a3841a7af8fc12e8a4044cd672df5614bfda8461b0ca45efa57a42c3bc8490e491ea490c6c05d319a52d69993c4fca33a0aeb044090e7b7f4e4e30c6517 remove-no-static-plt-test.patch
32ab4215669c728648179c124632467573a3d4675e79f0f0d221c22eb2ec1ca5488b79910bd09142f90a1e0d0b81d99ca4846297f4f9561f158db63745facb66 remove-pr2404-tests.patch
diff --git a/system/binutils/disable-ifunc-tests.patch b/system/binutils/disable-ifunc-tests.patch
new file mode 100644
index 000000000..6fbc5c874
--- /dev/null
+++ b/system/binutils/disable-ifunc-tests.patch
@@ -0,0 +1,12 @@
+--- binutils-2.30/ld/testsuite/ld-ifunc/ifunc.exp.old 2018-01-13 07:31:16.000000000 -0600
++++ binutils-2.30/ld/testsuite/ld-ifunc/ifunc.exp 2018-02-27 14:46:07.596544780 -0600
+@@ -36,7 +36,8 @@
+ || (([istarget "*-*-linux*"]
+ || [istarget "*-*-gnu*"])
+ && ![istarget "*-*-*aout*"]
+- && ![istarget "*-*-*oldld*"]))) } {
++ && ![istarget "*-*-*oldld*"]
++ && ![istarget "*-*-*musl*"]))) } {
+ verbose "IFUNC tests not run - target does not support IFUNC"
+ return
+ }
diff --git a/system/binutils/fix-plt-main-bnd-test.patch b/system/binutils/fix-plt-main-bnd-test.patch
deleted file mode 100644
index 867bf15f4..000000000
--- a/system/binutils/fix-plt-main-bnd-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- binutils-2.29/ld/testsuite/ld-x86-64/plt-main-bnd.dd.old 2017-07-04 08:43:21.000000000 +0000
-+++ binutils-2.29/ld/testsuite/ld-x86-64/plt-main-bnd.dd 2017-08-19 04:41:37.838409573 +0000
-@@ -1,7 +1,7 @@
- #...
- Disassembly of section .plt.got:
-
--[a-f0-9]+ <[a-z]+@plt>:
-+[a-f0-9]+ <[a-z_]+@plt>:
- [ ]*[a-f0-9]+: f2 ff 25 .. .. 20 00 bnd jmpq \*0x20....\(%rip\) # ...... <.*>
- [ ]*[a-f0-9]+: 90 nop
- #pass