summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/hwloc/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/hwloc/APKBUILD b/user/hwloc/APKBUILD
new file mode 100644
index 000000000..29f389fe2
--- /dev/null
+++ b/user/hwloc/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Dan Theisen <djt@hxx.in
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=hwloc
+pkgver=1.11.13
+_pkgver=${pkgver%.*}
+pkgrel=0
+pkgdesc="Hardware Locality library for portable system topology information"
+url="https://www.open-mpi.org/projects/hwloc/"
+arch="all"
+license="BSD-3-Clause"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.open-mpi.org/release/hwloc/v${_pkgver}/${pkgname}-${pkgver}.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="dd38bcc9a5df2dcfd3bbd828ab13fdb1c1d21747a0b62e6c87df95d2835c0472590344ff5bda4f6c28e597eaba1ea11c0bc96907ad45f1215f51f95ac9f58138 hwloc-1.11.13.tar.bz2"