summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/pcre2/APKBUILD10
-rw-r--r--system/pcre2/CVE-2019-20454.patch50
2 files changed, 5 insertions, 55 deletions
diff --git a/system/pcre2/APKBUILD b/system/pcre2/APKBUILD
index 4120d0a7b..75affce0d 100644
--- a/system/pcre2/APKBUILD
+++ b/system/pcre2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer:
pkgname=pcre2
-pkgver=10.33
-pkgrel=1
+pkgver=10.35
+pkgrel=0
pkgdesc="Perl-compatible regular expression library"
url="https://pcre.org"
arch="all"
@@ -13,12 +13,13 @@ makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcre2-16:_libpcre libpcre2-32:_libpcre"
source="https://ftp.pcre.org/pub/pcre/$pkgname-$pkgver.tar.gz
- CVE-2019-20454.patch
"
# secfixes:
# 10.33-r1:
# - CVE-2019-20454
+# 10.35-r0:
+# - CVE-2019-20454
case "$CARCH" in
s390x) _enable_jit="";;
@@ -68,5 +69,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="649983c7725e2fd2451ba89243b4c08c408fc279b7be3b2d225045cced3b0667ff6da4c9dd37510eb9e5aed6478aff54c2dbd1d92f4d0f1174579df9ec2c1882 pcre2-10.33.tar.gz
-07c43ccf130c1ed2b4f97036671f92e9c1d0100fd32c053b448e5dbdf976543c12f74568e37b661db7fbd603e815f5683a59cb2a9f9c307505dca3cb36db8120 CVE-2019-20454.patch"
+sha512sums="f9386de9211919da68ad0882dbfb72b344306280b3c4515f496cff4e3ff5c11e29fb71539a357a43a71ef668a742a54cc327a1dc3a00c767fbd0264933beecee pcre2-10.35.tar.gz"
diff --git a/system/pcre2/CVE-2019-20454.patch b/system/pcre2/CVE-2019-20454.patch
deleted file mode 100644
index bdec87294..000000000
--- a/system/pcre2/CVE-2019-20454.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Revision: 1091
-Author: ph10
-Date: Mon May 13 16:26:17 2019 UTC
-URL: https://vcs.pcre.org/pcre2?view=revision&revision=1091
-
-Fix crash when \X is used without UTF in JIT.
-
---- a/testdata/testinput4 2019/05/11 11:43:39 1090
-+++ b/testdata/testinput4 2019/05/13 16:26:17 1091
-@@ -2480,4 +2480,7 @@
- /^(?'אABC'...)(?&אABC)/utf
- 123123123456
-
-+/\X*/
-+ \xF3aaa\xE4\xEA\xEB\xFEa
-+
- # End of testinput4
---- a/testdata/testoutput4 2019/05/11 11:43:39 1090
-+++ b/testdata/testoutput4 2019/05/13 16:26:17 1091
-@@ -4012,4 +4012,8 @@
- 0: 123123
- 1: 123
-
-+/\X*/
-+ \xF3aaa\xE4\xEA\xEB\xFEa
-+ 0: \xf3aaa\xe4\xea\xeb\xfea
-+
- # End of testinput4
-
-Revision: 1092
-Author: ph10
-Date: Mon May 13 16:38:18 2019 UTC
-URL: https://vcs.pcre.org/pcre2?view=revision&revision=1092
-
-Forgot this file in previous commit. Fixes JIT non-UTF bug.
-
---- a/src/pcre2_jit_compile.c 2019/05/13 16:26:17 1091
-+++ b/src/pcre2_jit_compile.c 2019/05/13 16:38:18 1092
-@@ -8571,7 +8571,10 @@
- PCRE2_SPTR bptr;
- uint32_t c;
-
--GETCHARINC(c, cc);
-+/* Patch by PH */
-+/* GETCHARINC(c, cc); */
-+
-+c = *cc++;
- #if PCRE2_CODE_UNIT_WIDTH == 32
- if (c >= 0x110000)
- return NULL;