summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/kolourpaint/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/user/kolourpaint/APKBUILD b/user/kolourpaint/APKBUILD
new file mode 100644
index 000000000..654a0aa99
--- /dev/null
+++ b/user/kolourpaint/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=kolourpaint
+pkgver=17.12.2
+pkgrel=0
+pkgdesc="Simple painting program for KDE"
+url="http://www.kolourpaint.org/"
+arch="all"
+# yes, there is 2 only *and* 2+ code here.
+license="BSD-2-Clause AND LGPL-2.0-only AND LGPL-2.0+"
+depends=""
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev kdelibs4support-dev
+ libksane-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://download.kde.org/stable/applications/$pkgver/src/kolourpaint-$pkgver.tar.xz"
+builddir="$srcdir/kolourpaint-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="47965664a9749fad289f24975eddac726b266351820c2f94a82f714825d53c9bd6c37ff6f2cc30d47f8be759554c8f9682504e9b2acb4e95751b474f443fd527 kolourpaint-17.12.2.tar.xz"