summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/py3-urllib3/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/user/py3-urllib3/APKBUILD b/user/py3-urllib3/APKBUILD
new file mode 100644
index 000000000..48f33e87e
--- /dev/null
+++ b/user/py3-urllib3/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Yura Kushnir <kushnir.yura@gmail.com>
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-urllib3
+_pkgname=${pkgname#py3-}
+pkgver=1.23
+pkgrel=0
+pkgdesc="HTTP library with thread-safe connection pooling, file post, and more"
+url="https://github.com/shazow/urllib3"
+arch="noarch"
+options="!check" # needs tornado
+license="MIT"
+depends="py3-certifi py3-cryptography py3-idna py3-openssl py3-pysocks"
+makedepends="python3-dev"
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/shazow/urllib3/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="1d9eccdd2f939a1029fb6e49c45409b3a493f38b5880bba45a6e8a8088c0478190807b1fe7341b22abe363809ef41c5367de831de9618bcc62f34cb9f0cbc7af py3-urllib3-1.23.tar.gz"