summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/ol/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/ol/APKBUILD b/user/ol/APKBUILD
new file mode 100644
index 000000000..c475d92c3
--- /dev/null
+++ b/user/ol/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Yuriy Chumak <yuriy.chumak@mail.com>
+# Maintainer: Yuriy Chumak <yuriy.chumak@mail.com>
+pkgname=ol
+pkgver=2.4
+pkgrel=0
+pkgdesc="Purely functional dialect of Lisp"
+url="https://yuriy-chumak.github.io/ol/"
+arch="all"
+license="LGPL-3.0+ OR MIT"
+depends=""
+makedepends="vim"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/yuriy-chumak/$pkgname/archive/$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="019978ddcf0befc8b8de9f50899c9dd0f47a3e18cf9556bc72a75ae2d1d965d4 ol-2.4.tar.gz"