summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/iproute2/0001-f_flower-fix-build-with-musl-libc.patch28
-rw-r--r--system/iproute2/APKBUILD13
-rw-r--r--system/iproute2/devlink-sysinfo.patch43
-rw-r--r--system/iproute2/fix-uapi-garbage.patch22
4 files changed, 48 insertions, 58 deletions
diff --git a/system/iproute2/0001-f_flower-fix-build-with-musl-libc.patch b/system/iproute2/0001-f_flower-fix-build-with-musl-libc.patch
deleted file mode 100644
index 8a51affe5..000000000
--- a/system/iproute2/0001-f_flower-fix-build-with-musl-libc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 28747146622a49c3e7b5c5b36dc02c6a64124770 Mon Sep 17 00:00:00 2001
-From: Hans Dedecker <dedeckeh@gmail.com>
-Date: Wed, 23 Jan 2019 22:02:31 +0100
-Subject: [PATCH] f_flower: fix build with musl libc
-
-XATTR_SIZE_MAX requires the usage of linux/limits.h; let's include it
-
-Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
-Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
----
- tc/f_flower.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/tc/f_flower.c b/tc/f_flower.c
-index c5636667..9659e894 100644
---- a/tc/f_flower.c
-+++ b/tc/f_flower.c
-@@ -14,6 +14,7 @@
- #include <unistd.h>
- #include <string.h>
- #include <net/if.h>
-+#include <linux/limits.h>
- #include <linux/if_arp.h>
- #include <linux/if_ether.h>
- #include <linux/ip.h>
---
-2.19.2
-
diff --git a/system/iproute2/APKBUILD b/system/iproute2/APKBUILD
index 500a49f18..4b4b6060c 100644
--- a/system/iproute2/APKBUILD
+++ b/system/iproute2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=iproute2
-pkgver=4.20.0
+pkgver=5.1.0
pkgrel=0
pkgdesc="IP configuration, routing, and traffic control utilities"
url="https://wiki.linuxfoundation.org/networking/iproute2"
@@ -10,13 +10,11 @@ arch="all"
options="!check"
license="GPL-2.0-only"
depends=""
-makedepends="bison flex bash libelf-dev libmnl-dev libcap-dev"
+makedepends="bison flex bash libelf-dev libmnl-dev libcap-dev bsd-compat-headers"
install="$pkgname.post-install"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
- fix-uapi-garbage.patch
- 0001-f_flower-fix-build-with-musl-libc.patch
- "
+ devlink-sysinfo.patch"
prepare() {
default_prepare
@@ -54,6 +52,5 @@ bashcomp() {
rmdir -p "$pkgdir"/usr/share 2>/dev/null || true
}
-sha512sums="ed29638c864062e199152c7b3b24b6495987ca6f79cc9ab1b529dab37a8a840fa2b5858d5db2b94eeefa1c0d72ff666a790107e27d11a597b189bfb7a01a4b8b iproute2-4.20.0.tar.xz
-d9b40539f4ac074f20b0bb10381de9c3b64aadf612f0d599814cdb632fe97c76c9b4730406b08a6e53739670ca51ea0f699862156247cf20c3b7f4c78394fa46 fix-uapi-garbage.patch
-b6b5dc65fb4ffff06978c160446bcc79f4f242c94d0ba44890f3b01d86640f56e7cc32efbc0b2bbfce1ae5fd40252ba9ddbb59ff91e54a4de1d4274d48260b2c 0001-f_flower-fix-build-with-musl-libc.patch"
+sha512sums="5c8319b040bd0ba98cf1225b2a77efafc662741344c53877ee38cf108ca01906b03328e4f9b00b7557e301c6e64bca4e42e92af477b4d657bcbff5120c0c4e87 iproute2-5.1.0.tar.xz
+3585c70d110749e0bdba7f1bbdc32c7d635147026fbb9662f63dfcca2405e8a45cc990cb6ad38b6405cde23a1535a59ff854387ae1649b4241597ec71f445e20 devlink-sysinfo.patch"
diff --git a/system/iproute2/devlink-sysinfo.patch b/system/iproute2/devlink-sysinfo.patch
new file mode 100644
index 000000000..316fcefae
--- /dev/null
+++ b/system/iproute2/devlink-sysinfo.patch
@@ -0,0 +1,43 @@
+Since commit 2f1242efe9d ("devlink: Add devlink health show command") we
+use the sys/sysinfo.h header for the sysinfo(2) system call. But since
+iproute2 carries a local version of the kernel struct sysinfo, this
+causes a collision with libc that do not rely on kernel defined sysinfo
+like musl libc:
+
+In file included from devlink.c:25:0:
+.../sysroot/usr/include/sys/sysinfo.h:10:8: error: redefinition of 'struct sysinfo'
+ struct sysinfo {
+ ^~~~~~~
+In file included from ../include/uapi/linux/kernel.h:5:0,
+ from ../include/uapi/linux/netlink.h:5,
+ from ../include/uapi/linux/genetlink.h:6,
+ from devlink.c:21:
+../include/uapi/linux/sysinfo.h:8:8: note: originally defined here
+ struct sysinfo {
+ ^~~~~~~
+
+Rely on the kernel header alone to avoid kernel and userspace headers
+collision of definitions.
+
+Cc: Aya Levin <ayal@xxxxxxxxxxxx>
+Cc: Moshe Shemesh <moshe@xxxxxxxxxxxx>
+Signed-off-by: Baruch Siach <baruch@xxxxxxxxxx>
+---
+ devlink/devlink.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/devlink/devlink.c b/devlink/devlink.c
+index 436935f88bda..d7a6ce94f0e6 100644
+--- a/devlink/devlink.c
++++ b/devlink/devlink.c
+@@ -22,7 +22,7 @@
+ #include <linux/devlink.h>
+ #include <libmnl/libmnl.h>
+ #include <netinet/ether.h>
+-#include <sys/sysinfo.h>
++#include <linux/sysinfo.h>
+ #include <sys/queue.h>
+
+ #include "SNAPSHOT.h"
+--
+2.20.1 \ No newline at end of file
diff --git a/system/iproute2/fix-uapi-garbage.patch b/system/iproute2/fix-uapi-garbage.patch
deleted file mode 100644
index 9f899ebb0..000000000
--- a/system/iproute2/fix-uapi-garbage.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- iproute2-4.17.0/rdma/rdma.h 2018-06-08 12:11:50.000000000 -0500
-+++ iproute2-4.17.0/rdma/rdma.h 2018-06-25 23:26:35.811455508 -0500
-@@ -16,15 +16,16 @@
- #include <errno.h>
- #include <getopt.h>
- #include <libmnl/libmnl.h>
--#include <rdma/rdma_netlink.h>
--#include <rdma/rdma_user_cm.h>
- #include <time.h>
--#include <net/if_arp.h>
-
- #include "list.h"
- #include "utils.h"
- #include "json_writer.h"
-
-+#include <rdma/rdma_netlink.h>
-+#include <rdma/rdma_user_cm.h>
-+#include <net/if_arp.h>
-+
- #define pr_err(args...) fprintf(stderr, ##args)
- #define pr_out(args...) fprintf(stdout, ##args)
-