summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/yajl/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/user/yajl/APKBUILD b/user/yajl/APKBUILD
new file mode 100644
index 000000000..4219b8c20
--- /dev/null
+++ b/user/yajl/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=yajl
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Yet Another JSON Library (YAJL)"
+url="http://lloyd.github.com/yajl/"
+arch="all"
+license="ISC"
+depends=""
+makedepends="cmake"
+install=""
+subpackages="$pkgname-dev $pkgname-tools"
+source="yajl-$pkgver.tar.gz::https://github.com/lloyd/yajl/archive/$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" .
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+ mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib/
+}
+
+check() {
+ cd "$builddir"
+ make test
+ # make test-api just checks the return status of gen-extra-close
+ # and also forkbombs, so elide that
+}
+
+tools() {
+ pkgdesc="JSON tools based on Yajl"
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+
+sha512sums="9e786d080803df80ec03a9c2f447501e6e8e433a6baf636824bc1d50ecf4f5f80d7dfb1d47958aeb0a30fe459bd0ef033d41bc6a79e1dc6e6b5eade930b19b02 yajl-2.1.0.tar.gz"