summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/py3-pbr/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/py3-pbr/APKBUILD b/user/py3-pbr/APKBUILD
new file mode 100644
index 000000000..3619ca8c6
--- /dev/null
+++ b/user/py3-pbr/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-pbr
+_pkgname=${pkgname#py3-}
+pkgver=5.1.1
+pkgrel=0
+pkgdesc="Python Build Reasonableness"
+url="https://pypi.python.org/pypi/pbr"
+arch="noarch"
+options="!check" # needs fixtures, git, hacking, sphinx, stestr, test{resources,scenarios,tools}
+license="Apache-2.0"
+depends=""
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="cd6f8bdc6db80841e948dbb278423556861aa681b970050a40c920dd00e32704a29cfdd28aabd4d14e0e577fff1bc816f0646a62c9450d0d85233ab5802606f1 pbr-5.1.1.tar.gz"