summaryrefslogtreecommitdiff
path: root/bootstrap/rust-1.68/0010-Ignore-broken-and-non-applicable-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'bootstrap/rust-1.68/0010-Ignore-broken-and-non-applicable-tests.patch')
-rw-r--r--bootstrap/rust-1.68/0010-Ignore-broken-and-non-applicable-tests.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/bootstrap/rust-1.68/0010-Ignore-broken-and-non-applicable-tests.patch b/bootstrap/rust-1.68/0010-Ignore-broken-and-non-applicable-tests.patch
new file mode 100644
index 000000000..16bdf6f62
--- /dev/null
+++ b/bootstrap/rust-1.68/0010-Ignore-broken-and-non-applicable-tests.patch
@@ -0,0 +1,58 @@
+From 7ffd07fcdf49f0c4a4e5becfc773c594b86e6dc9 Mon Sep 17 00:00:00 2001
+From: Samuel Holland <samuel@sholland.org>
+Date: Sun, 16 Sep 2018 16:38:48 +0000
+Subject: [PATCH 10/13] Ignore broken and non-applicable tests
+
+c-link-to-rust-va-list-fn: unstable feature, broken on aarch64, #56475
+env-funky-keys: can't handle LD_PRELOAD (e.g. sandbox)
+long-linker-command-lines: takes >10 minutes to run (but still passes)
+sysroot-crates-are-unstable: can't run rustc without RPATH
+---
+ tests/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile | 2 ++
+ tests/run-make-fulldeps/long-linker-command-lines/Makefile | 2 ++
+ tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile | 2 ++
+ tests/ui/env-funky-keys.rs | 1 +
+ 4 files changed, 7 insertions(+)
+
+diff --git a/tests/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile b/tests/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile
+index 9ce2a34e677b3..fa1892d6cb3e9 100644
+--- a/tests/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile
++++ b/tests/run-make-fulldeps/c-link-to-rust-va-list-fn/Makefile
+@@ -1,3 +1,5 @@
++# ignore-aarch64
++
+ include ../tools.mk
+
+ all:
+diff --git a/tests/run-make-fulldeps/long-linker-command-lines/Makefile b/tests/run-make-fulldeps/long-linker-command-lines/Makefile
+index 00199ca970d3d..3839663eac481 100644
+--- a/tests/run-make-fulldeps/long-linker-command-lines/Makefile
++++ b/tests/run-make-fulldeps/long-linker-command-lines/Makefile
+@@ -1,3 +1,5 @@
++# ignore-test
++
+ include ../tools.mk
+
+ all:
+diff --git a/tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile b/tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+index 30c33c5c13d20..d733bb1c557f5 100644
+--- a/tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
++++ b/tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+@@ -1,3 +1,5 @@
++# ignore-test
++
+ -include ../tools.mk
+
+ all:
+diff --git a/tests/ui/env-funky-keys.rs b/tests/ui/env-funky-keys.rs
+index 46e20d8c61f52..b598ebfbb45a1 100644
+--- a/tests/ui/env-funky-keys.rs
++++ b/tests/ui/env-funky-keys.rs
+@@ -1,6 +1,7 @@
+ // run-pass
+ // Ignore this test on Android, because it segfaults there.
+
++// ignore-test
+ // ignore-android
+ // ignore-windows
+ // ignore-emscripten no execve