summaryrefslogtreecommitdiff
path: root/bootstrap/rust-1.79/0009-Ignore-broken-and-non-applicable-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'bootstrap/rust-1.79/0009-Ignore-broken-and-non-applicable-tests.patch')
-rw-r--r--bootstrap/rust-1.79/0009-Ignore-broken-and-non-applicable-tests.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/bootstrap/rust-1.79/0009-Ignore-broken-and-non-applicable-tests.patch b/bootstrap/rust-1.79/0009-Ignore-broken-and-non-applicable-tests.patch
new file mode 100644
index 000000000..51f1f7ee3
--- /dev/null
+++ b/bootstrap/rust-1.79/0009-Ignore-broken-and-non-applicable-tests.patch
@@ -0,0 +1,60 @@
+From cc6d3d3ab26517d5f8f09536b016154944bdceff Mon Sep 17 00:00:00 2001
+From: Samuel Holland <samuel@sholland.org>
+Date: Sun, 16 Sep 2018 16:38:48 +0000
+Subject: [PATCH 09/12] Ignore broken and non-applicable tests
+
+c-link-to-rust-va-list-fn: unstable feature, broken on aarch64, #56475
+env-funky-keys: can't handle LD_PRELOAD (e.g. sandbox)
+long-linker-command-lines: takes >10 minutes to run (but still passes)
+sysroot-crates-are-unstable: can't run rustc without RPATH
+---
+ tests/run-make/c-link-to-rust-va-list-fn/Makefile | 2 ++
+ tests/run-make/long-linker-command-lines/Makefile | 2 ++
+ tests/run-make/sysroot-crates-are-unstable/Makefile | 2 ++
+ tests/ui/env-funky-keys.rs | 1 +
+ 4 files changed, 7 insertions(+)
+
+diff --git a/tests/run-make/c-link-to-rust-va-list-fn/Makefile b/tests/run-make/c-link-to-rust-va-list-fn/Makefile
+index 596c0fce3ceae..3a156893f9199 100644
+--- a/tests/run-make/c-link-to-rust-va-list-fn/Makefile
++++ b/tests/run-make/c-link-to-rust-va-list-fn/Makefile
+@@ -1,4 +1,6 @@
+ # ignore-cross-compile
++# ignore-aarch64
++
+ include ../tools.mk
+
+ all:
+diff --git a/tests/run-make/long-linker-command-lines/Makefile b/tests/run-make/long-linker-command-lines/Makefile
+index f864ea74f4a95..f16eaf544cc3f 100644
+--- a/tests/run-make/long-linker-command-lines/Makefile
++++ b/tests/run-make/long-linker-command-lines/Makefile
+@@ -1,4 +1,6 @@
+ # ignore-cross-compile
++# ignore-test
++
+ include ../tools.mk
+
+ export LD_LIBRARY_PATH := $(HOST_RPATH_DIR)
+diff --git a/tests/run-make/sysroot-crates-are-unstable/Makefile b/tests/run-make/sysroot-crates-are-unstable/Makefile
+index 30c33c5c13d20..d733bb1c557f5 100644
+--- a/tests/run-make/sysroot-crates-are-unstable/Makefile
++++ b/tests/run-make/sysroot-crates-are-unstable/Makefile
+@@ -1,3 +1,5 @@
++# ignore-test
++
+ -include ../tools.mk
+
+ all:
+diff --git a/tests/ui/env-funky-keys.rs b/tests/ui/env-funky-keys.rs
+index 314ccaea01525..7f5b9efaa10b1 100644
+--- a/tests/ui/env-funky-keys.rs
++++ b/tests/ui/env-funky-keys.rs
+@@ -1,6 +1,7 @@
+ //@ run-pass
+ // Ignore this test on Android, because it segfaults there.
+
++//@ ignore-test
+ //@ ignore-android
+ //@ ignore-windows
+ //@ ignore-wasm32 no execve