summaryrefslogtreecommitdiff
path: root/legacy/hwdata/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'legacy/hwdata/APKBUILD')
-rw-r--r--legacy/hwdata/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/legacy/hwdata/APKBUILD b/legacy/hwdata/APKBUILD
new file mode 100644
index 000000000..a25f9b891
--- /dev/null
+++ b/legacy/hwdata/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer:
+pkgname=hwdata
+pkgver=0.316
+pkgrel=0
+pkgdesc="Hardware identification and configuration data"
+url="https://github.com/vcrhonek/hwdata"
+arch="noarch"
+options="!check" # requires pciutils, which causes build loop
+license="GPL-2.0+"
+subpackages="$pkgname-usb $pkgname-pci $pkgname-pnp $pkgname-oui"
+depends="$subpackages"
+makedepends="bash"
+source="$pkgname-$pkgver.tar.gz::https://github.com/vcrhonek/hwdata/archive/v$pkgver.tar.gz
+ install-T.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --datadir=/usr/share
+ # nothing to make
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+ # remove modprobe blacklist
+ rm -r "$pkgdir"/usr/lib
+}
+
+_mv() {
+ pkgdesc="$pkgdesc - $1"
+ depends=""
+ mkdir -p "$subpkgdir"/usr/share/hwdata
+ mv "$pkgdir"/usr/share/hwdata/$1 "$subpkgdir"/usr/share/hwdata
+}
+
+usb() { replaces="usbutils"; _mv usb.ids; }
+pci() { replaces="pciutils"; _mv pci.ids; }
+pnp() { _mv pnp.ids; }
+oui() { _mv oui.txt; }
+
+sha512sums="8d43b91e6c410c43d6831f793a8e5a71903072ebc72cfd3414fa70fb76efaa873474bfbdd6af015970c3e43f7ba65eaa4e0a781f87ad1170be82afc793ef6d3c hwdata-0.316.tar.gz
+88a786d8feb5c8b7de587ac70f3e4307d10ac5ed9b0edfc8711de1ba51808ca33a76df518cb5a508215c309289a079a778a91c3e6fc359d644d230de8d23f049 install-T.patch"