summaryrefslogtreecommitdiff
path: root/system/apr-util/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/apr-util/APKBUILD')
-rw-r--r--system/apr-util/APKBUILD64
1 files changed, 0 insertions, 64 deletions
diff --git a/system/apr-util/APKBUILD b/system/apr-util/APKBUILD
deleted file mode 100644
index 415c3e9cd..000000000
--- a/system/apr-util/APKBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=apr-util
-pkgver=1.6.1
-pkgrel=0
-pkgdesc="The Apache Portable Runtime Utility Library"
-url="http://apr.apache.org/"
-arch="all"
-license="ASL 2.0"
-depends=
-subpackages="$pkgname-dev $pkgname-dbm_db $pkgname-dbd_pgsql
- $pkgname-dbd_sqlite3 $pkgname-ldap"
-
-depends_dev="expat-dev apr-dev openldap-dev sqlite-dev postgresql-dev
- db-dev openssl-dev"
-makedepends="$depends_dev bash chrpath openssl"
-source="http://www.apache.org/dist/apr/$pkgname-$pkgver.tar.bz2"
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --with-apr=/usr \
- --with-ldap \
- --with-pgsql \
- --with-sqlite3 \
- --with-berkeley-db \
- --with-crypto \
- --with-openssl \
- --without-sqlite2 \
- --without-gdbm
- make
-}
-
-check() {
- cd "$builddir"
- # testxlate fails because UTF-7 is unsupported
- make check || return 0
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- rm "$pkgdir"/usr/lib/*.exp
- chrpath -d "$pkgdir"/usr/lib/*.so.*
-}
-
-_mv_mod() {
- pkgdesc="The Apache Portable Runtime Utility Library - $2 driver"
- depends=
- local _moddir="usr/lib/apr-util-1"
- mkdir -p "$subpkgdir"/$_moddir
- mv "$pkgdir"/$_moddir/apr_$1*.so "$subpkgdir"/$_moddir/
-}
-
-dbm_db() { _mv_mod dbm_db "Berkley DB"; }
-dbd_pgsql() { _mv_mod dbd_pgsql "PostgreSQL"; }
-dbd_mysql() { _mv_mod dbd_mysql "MySQL"; }
-dbd_sqlite3() { _mv_mod dbd_sqlite "SQLite3"; }
-ldap() { _mv_mod ldap "LDAP"; }
-
-sha512sums="40eff8a37c0634f7fdddd6ca5e596b38de15fd10767a34c30bbe49c632816e8f3e1e230678034f578dd5816a94f246fb5dfdf48d644829af13bf28de3225205d apr-util-1.6.1.tar.bz2"