summaryrefslogtreecommitdiff
path: root/system/ed/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/ed/APKBUILD')
-rw-r--r--system/ed/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/system/ed/APKBUILD b/system/ed/APKBUILD
index 38acc491c..d13ab5a2b 100644
--- a/system/ed/APKBUILD
+++ b/system/ed/APKBUILD
@@ -2,7 +2,7 @@
pkgname=ed
pkgver=1.15
pkgrel=0
-pkgdesc="GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files"
+pkgdesc="GNU version of standard text editor"
url="https://www.gnu.org/software/ed/"
arch="all"
license="GPL-3.0+"
@@ -14,24 +14,19 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.lz"
builddir=$srcdir/$pkgname-$pkgver
build() {
- cd "$builddir"
- # bindir needs correspond with busybox location
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --bindir=/bin \
--mandir=/usr/share/man
make all
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}