summaryrefslogtreecommitdiff
path: root/system/file/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/file/APKBUILD')
-rw-r--r--system/file/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/system/file/APKBUILD b/system/file/APKBUILD
index 86a09ce68..da9059a2b 100644
--- a/system/file/APKBUILD
+++ b/system/file/APKBUILD
@@ -8,17 +8,17 @@ pkgdesc="File type identification utility"
url="http://www.darwinsys.com/file/"
arch="all"
license="BSD-2-Clause"
+depends=""
+makedepends="autoconf automake"
subpackages="$pkgname-dev $pkgname-doc libmagic"
source="$pkgname-$pkgver.tar.gz::https://github.com/file/file/archive/FILE${pkgver%.*}_${pkgver#*.}.tar.gz"
builddir="$srcdir/$pkgname-FILE${pkgver%.*}_${pkgver#*.}"
prepare() {
- cd "$builddir"
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}