summaryrefslogtreecommitdiff
path: root/system/help2man
diff options
context:
space:
mode:
Diffstat (limited to 'system/help2man')
-rw-r--r--system/help2man/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/system/help2man/APKBUILD b/system/help2man/APKBUILD
new file mode 100644
index 000000000..4e137d42f
--- /dev/null
+++ b/system/help2man/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=help2man
+pkgver=1.47.6
+pkgrel=1
+pkgdesc="Create simple man pages from --help output"
+url="https://www.gnu.org/software/help2man"
+arch="noarch"
+options="!check" # No test suite
+license="GPL-3.0+"
+depends="perl"
+makedepends="gettext-tiny"
+subpackages="$pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/help2man/help2man-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d24849b93de58b20f518c071687e7bfa653a96600382f36c4cf7fc1047656458f75f093b911b786b18b6931b2453cb60868ecbe07cc7d2984e5981a874b34942 help2man-1.47.6.tar.xz"