summaryrefslogtreecommitdiff
path: root/system/json-c/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/json-c/APKBUILD')
-rw-r--r--system/json-c/APKBUILD8
1 files changed, 1 insertions, 7 deletions
diff --git a/system/json-c/APKBUILD b/system/json-c/APKBUILD
index e5c44cfe8..32ee431dd 100644
--- a/system/json-c/APKBUILD
+++ b/system/json-c/APKBUILD
@@ -7,22 +7,18 @@ url="https://github.com/json-c/json-c/wiki"
arch="all"
license="MIT"
depends=""
-depends_dev=""
-makedepends="$depends_dev autoconf automake libtool"
-install=""
+makedepends="autoconf automake libtool"
subpackages="$pkgname-static $pkgname-dev"
source="https://s3.amazonaws.com/${pkgname}_releases/releases/$pkgname-${pkgver}.tar.gz
fix-libdir.patch
"
prepare() {
- cd "$builddir"
default_prepare
autoreconf -f -v -i
}
build() {
- cd "$builddir"
export CFLAGS="${CFLAGS} -Wno-error=unused-but-set-variable"
./configure --prefix=/usr \
--build=$CBUILD \
@@ -39,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}