summaryrefslogtreecommitdiff
path: root/system/linux-pam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/linux-pam/APKBUILD')
-rw-r--r--system/linux-pam/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/system/linux-pam/APKBUILD b/system/linux-pam/APKBUILD
index 0d1221a0d..44b603644 100644
--- a/system/linux-pam/APKBUILD
+++ b/system/linux-pam/APKBUILD
@@ -6,12 +6,12 @@ pkgrel=2
pkgdesc="Pluggable Authentication Modules"
url="https://www.kernel.org/pub/linux/libs/pam"
arch="all"
+options="suid"
license="BSD-3-Clause"
depends_dev="gettext-tiny-dev"
makedepends_host="$depends_dev utmps-dev"
makedepends_build="$depends_dev byacc flex-dev autoconf automake libtool"
makedepends="$makedepends_host $makedepends_build"
-options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://github.com/$pkgname/$pkgname/releases/download/v1.3.1/Linux-PAM-$pkgver.tar.xz
fix-compat.patch
@@ -27,17 +27,15 @@ source="https://github.com/$pkgname/$pkgname/releases/download/v1.3.1/Linux-PAM-
other.pamd
su.pamd
"
-
builddir="$srcdir"/Linux-PAM-$pkgver
+
prepare() {
- cd "$builddir"
default_prepare
# disable insecure modules
sed -e 's/pam_rhosts//g' -i modules/Makefile.am
}
build() {
- cd "$builddir"
autoreconf -vif
[ "$CLIBC" = "musl" ] && export ac_cv_search_crypt=no
LIBS="-lutmps -lskarnet" ./configure \
@@ -54,12 +52,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# do not install pam.d files bundled with the source, they could be broken