summaryrefslogtreecommitdiff
path: root/system/lutok/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/lutok/APKBUILD')
-rw-r--r--system/lutok/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/system/lutok/APKBUILD b/system/lutok/APKBUILD
new file mode 100644
index 000000000..61106b7b3
--- /dev/null
+++ b/system/lutok/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=lutok
+pkgver=0.4
+pkgrel=2
+pkgdesc="Lightweight C++ API for Lua"
+url="https://github.com/jmmv/lutok"
+arch="all"
+license="BSD"
+depends_dev="lua5.3-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/jmmv/lutok/releases/download/lutok-$pkgver/lutok-$pkgver.tar.gz"
+builddir="$srcdir/lutok-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+
+ LUA_CFLAGS=$(pkg-config --cflags lua5.3) \
+ LUA_LIBS=$(pkg-config --libs lua5.3) \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="664f30099bfbb30978e24068a9232a4ff1b5b1839c601bf784f35f6bb1394558067495093a3b0343c94e756d2e4186a32a8227baf5934c15c45905f7c0a5d19c lutok-0.4.tar.gz"