summaryrefslogtreecommitdiff
path: root/system/lutok/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/lutok/APKBUILD')
-rw-r--r--system/lutok/APKBUILD6
1 files changed, 0 insertions, 6 deletions
diff --git a/system/lutok/APKBUILD b/system/lutok/APKBUILD
index 103688367..4ee59e386 100644
--- a/system/lutok/APKBUILD
+++ b/system/lutok/APKBUILD
@@ -10,17 +10,13 @@ depends_dev="lua5.3-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/jmmv/lutok/releases/download/lutok-$pkgver/lutok-$pkgver.tar.gz"
-builddir="$srcdir/lutok-$pkgver"
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
}
build() {
- cd "$builddir"
-
LUA_CFLAGS=$(pkg-config --cflags lua5.3) \
LUA_LIBS=$(pkg-config --libs lua5.3) \
./configure \
@@ -34,12 +30,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}