summaryrefslogtreecommitdiff
path: root/system/mpc1/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/mpc1/APKBUILD')
-rw-r--r--system/mpc1/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/system/mpc1/APKBUILD b/system/mpc1/APKBUILD
new file mode 100644
index 000000000..6552a588d
--- /dev/null
+++ b/system/mpc1/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mpc1
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Multiprecision C library"
+url="http://www.multiprecision.org/"
+arch="all"
+license="LGPL-2.1"
+depends=
+makedepends_host="gmp-dev mpfr-dev"
+makedepends="$makedepends_host"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnu.org/gnu/mpc/mpc-$pkgver.tar.gz"
+
+builddir="$srcdir"/mpc-$pkgver
+
+build() {
+ cd "$builddir"
+ # workaround for a bug in configure script
+ EGREP=egrep \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --with-sysroot="${CBUILDROOT}" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-shared
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="d6a1d5f8ddea3abd2cc3e98f58352d26 mpc-1.0.3.tar.gz"
+sha256sums="617decc6ea09889fb08ede330917a00b16809b8db88c29c31bfbb49cbf88ecc3 mpc-1.0.3.tar.gz"
+sha512sums="0028b76df130720c1fad7de937a0d041224806ce5ef76589f19c7b49d956071a683e2f20d154c192a231e69756b19e48208f2889b0c13950ceb7b3cfaf059a43 mpc-1.0.3.tar.gz"