summaryrefslogtreecommitdiff
path: root/system/musl
diff options
context:
space:
mode:
Diffstat (limited to 'system/musl')
-rw-r--r--system/musl/APKBUILD4
-rw-r--r--system/musl/ppc-hwcap.patch36
2 files changed, 39 insertions, 1 deletions
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 9816d009e..a8e6c7daa 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
pkgver=1.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="System library (libc) implementation"
url="https://www.musl-libc.org/"
arch="all"
@@ -26,6 +26,7 @@ source="https://musl.libc.org/releases/musl-${pkgver}.tar.gz
3001-make-real-lastlog-h.patch
handle-aux-at_base.patch
fgetspent_r.patch
+ ppc-hwcap.patch
realpath.patch
signed-wchar_t-fixes.patch
@@ -125,6 +126,7 @@ f7b05d8c5f804ba3ad6998b3de5fa4d9dfceac4aca63dd67298c2d5f27cdd28a91eba74f6e428c25
88ae443dbb8e0a4368235bdc3a1c5c7b718495afa75e06deb8e01becc76cb1f0d6964589e2204fc749c9c1b3190b8b9ac1ae2c0099cab8e2ce3ec877103d4332 3001-make-real-lastlog-h.patch
1f4e9aea5a546015c75f77aa0dec10d56fc14831ccc15cf71ff27fc15ac5230ffeadb382ebe1c87c1ea07a462620e16ed01cd36252d997d1a9c2af11cb5c9ff3 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
+96d88bb9c03f6eddcfc22cbd04efa73535f4ab78409954a042a2e08294cc8df1fb2cb0475eadb92a7fa281229abaa600f034d3ef08e918c6016dbf9be1db28d9 ppc-hwcap.patch
d5ec3f1a86f2194e0af83c2391508811b939d0f8f2fd2ac5ac7f03774f8a250ce42399110d2ae04d32b864ee292863fed683a029b64598dbbcb21d9811a825d0 realpath.patch
3770af3bc961e5d5b8c152c428cd20dc54e026b23b31d764fbc2e71ee38140d160db2267755f23800bc8586fd4b51554b1caebb2415bef82fd0f4a6dd8bf640d signed-wchar_t-fixes.patch
cb71d29a87f334c75ecbc911becde7be825ab30d8f39fa6d64cb53812a7c9abaf91d9804c72540e5be3ddd3c84cfe7fd9632274309005cb8bcdf9a9b09b4b923 ldconfig
diff --git a/system/musl/ppc-hwcap.patch b/system/musl/ppc-hwcap.patch
new file mode 100644
index 000000000..3ebd5c42b
--- /dev/null
+++ b/system/musl/ppc-hwcap.patch
@@ -0,0 +1,36 @@
+From 2c788798c1f625c42e844311f5a5d2e19707d581 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Fri, 3 Jan 2025 13:36:33 -0600
+Subject: [PATCH] powerpc: Update HWCAP bits for Power10
+
+Linux kernel commit ee988c11acf6f9464b7b44e9a091bf6afb3b3a49 added two
+new HWCAP bits: one for ARCH_3_1, which is the Power10 ISA revision, and
+one for MMA, which is the optional Matrix Multiply Assist extension.
+---
+ arch/powerpc/bits/hwcap.h | 2 ++
+ arch/powerpc64/bits/hwcap.h | 2 ++
+ 2 files changed, 4 insertions(+)
+
+diff --git a/arch/powerpc/bits/hwcap.h b/arch/powerpc/bits/hwcap.h
+index 803de9b5..12981623 100644
+--- a/arch/powerpc/bits/hwcap.h
++++ b/arch/powerpc/bits/hwcap.h
+@@ -41,3 +41,5 @@
+ #define PPC_FEATURE2_DARN 0x00200000
+ #define PPC_FEATURE2_SCV 0x00100000
+ #define PPC_FEATURE2_HTM_NO_SUSPEND 0x00080000
++#define PPC_FEATURE2_ARCH_3_1 0x00040000
++#define PPC_FEATURE2_MMA 0x00020000
+diff --git a/arch/powerpc64/bits/hwcap.h b/arch/powerpc64/bits/hwcap.h
+index 803de9b5..12981623 100644
+--- a/arch/powerpc64/bits/hwcap.h
++++ b/arch/powerpc64/bits/hwcap.h
+@@ -41,3 +41,5 @@
+ #define PPC_FEATURE2_DARN 0x00200000
+ #define PPC_FEATURE2_SCV 0x00100000
+ #define PPC_FEATURE2_HTM_NO_SUSPEND 0x00080000
++#define PPC_FEATURE2_ARCH_3_1 0x00040000
++#define PPC_FEATURE2_MMA 0x00020000
+--
+2.40.0
+