summaryrefslogtreecommitdiff
path: root/system/nss/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/nss/APKBUILD')
-rw-r--r--system/nss/APKBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/system/nss/APKBUILD b/system/nss/APKBUILD
index 687e938fd..944668272 100644
--- a/system/nss/APKBUILD
+++ b/system/nss/APKBUILD
@@ -3,7 +3,7 @@
pkgname=nss
pkgver=3.51
_ver=$(printf '%s' "$pkgver" | tr . _)
-pkgrel=0
+pkgrel=1
pkgdesc="Mozilla Network Security Services"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS"
arch="all"
@@ -49,6 +49,17 @@ build() {
case "$CARCH" in
*64* | s390x) export USE_64=1;;
esac
+
+ # This actually enables -mvsx and -mcrypto too, and those can't
+ # be turned off separately in this case:
+ #
+ # altivec-types.h:20:1: error: use of _long long_ in AltiVec
+ # types is invalid without _-mvsx_
+ #
+ # typedef __vector signed long long vec_s64;
+ # ^~~~~~~
+ export NSS_DISABLE_ALTIVEC=1
+
make -j 1 -C nss/coreconf
make -j 1 -C nss/lib/dbm
make -j 1 -C nss