summaryrefslogtreecommitdiff
path: root/system/perl-lwp-mediatypes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-lwp-mediatypes/APKBUILD')
-rw-r--r--system/perl-lwp-mediatypes/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/system/perl-lwp-mediatypes/APKBUILD b/system/perl-lwp-mediatypes/APKBUILD
new file mode 100644
index 000000000..c2fdb7f43
--- /dev/null
+++ b/system/perl-lwp-mediatypes/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-lwp-mediatypes
+_realname=LWP-MediaTypes
+pkgver=6.02
+pkgrel=2
+pkgdesc="Perl module - guess media type for a file or a URL"
+url="http://search.cpan.org/~gaas"
+arch="noarch"
+license="GPL-2.0-only OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+install=
+replaces="perl-libwww"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+sha512sums="b2ad33fb2c6dd7afaa9b8dd2ed6a15b2ecc35d13bcdf5297ce1632ea77406def0840a24c5213187707b665f28cc9bbea5774bfd1a4070d1f6192e904f707b94e LWP-MediaTypes-6.02.tar.gz"