summaryrefslogtreecommitdiff
path: root/system/perl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl/APKBUILD')
-rw-r--r--system/perl/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index 40277eb72..88d72cf5a 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -2,22 +2,20 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
-# Proxy-For: solar
pkgname=perl
-pkgver=5.26.3
-pkgrel=2
+pkgver=5.34.0
+pkgrel=0
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url="https://www.perl.org/"
arch="all"
-# remove !check when tests pass.
-options="!check !fhs"
+options="!fhs"
license="Artistic-1.0-Perl GPL-2.0"
depends=""
makedepends="bzip2-dev zlib-dev"
subpackages="$pkgname-doc $pkgname-dev"
-# XXX - Remove Getopt::Long when upgrading to 5.32+
source="https://www.cpan.org/src/5.0/perl-$pkgver.tar.gz
- https://cpan.metacpan.org/authors/id/J/JV/JV/Getopt-Long-2.51.tar.gz
+ musl-locale.patch
+ CVE-2021-36770.patch
"
# secfixes:
@@ -47,9 +45,6 @@ prepare() {
rm -rf cpan/Compress-Raw-Zlib/zlib-src
rm -rf cpan/Compress-Raw-Bzip2/bzip2-src
sed -i '/\(bzip2\|zlib\)-src/d' MANIFEST
-
- rm -rf cpan/Getopt-Long && mv "$srcdir"/Getopt-Long-2.51 cpan/Getopt-Long
- rm cpan/Getopt-Long/Makefile.PL
}
build() {
@@ -91,7 +86,7 @@ build() {
}
check() {
- make test
+ TEST_JOBS=$JOBS make test_harness
}
package() {
@@ -116,5 +111,6 @@ dev() {
default_dev
}
-sha512sums="03914ed51163c998a6afa45610a13cf50124a2c68d291c344b0d52fa15c27fc5d5d4f5dc117516078a03dfd51250097b87c8d5e2b17c7858a4c8c536aecd05af perl-5.26.3.tar.gz
-e70b2c30f5f85d7bf387381782a22b55f76598e1b4e19102fbf463c4333e91090ad2da49965be6211821d4f7f109aa7e4153348a9142f38fdb1a39299c997c02 Getopt-Long-2.51.tar.gz"
+sha512sums="3bd2ae3900df54801b42a1ab1c136b20438f3a162d88c1e030c5d91e96ad5cf76d5ccbcf9e75388fa29bcc26db0b1c5df3d1240d48136159462c912c9258d405 perl-5.34.0.tar.gz
+a78b5fb1a2b6f60b401329cfd2d8349d4fdcc19628cde0e9b840b82e1a02e705f7d7413fe206aa13ed714ab93a65b62ac3d85dfd526ca8048621d5d89b22f0ef musl-locale.patch
+2eb4986ac56f394e584ed5b16be40ccc0b689512fc23746588a3947db49c53be96dbbc25b8256513142c7a613481ea11b9154dfd4d0a67f05ef0662fedfd476a CVE-2021-36770.patch"