summaryrefslogtreecommitdiff
path: root/system/rsync/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/rsync/APKBUILD')
-rw-r--r--system/rsync/APKBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/system/rsync/APKBUILD b/system/rsync/APKBUILD
index 09b1d6515..728a32fbc 100644
--- a/system/rsync/APKBUILD
+++ b/system/rsync/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=rsync
pkgver=3.1.3
-pkgrel=0
-pkgdesc="A file transfer program to keep remote files in sync"
+pkgrel=2
+pkgdesc="File transfer program to keep remote files in sync"
url="https://rsync.samba.org/"
arch="all"
license="GPL-3.0+"
-makedepends="perl acl-dev attr-dev popt-dev"
+depends=""
+checkdepends="fakeroot"
+makedepends="perl acl-dev attr-dev popt-dev zlib-dev"
subpackages="$pkgname-doc $pkgname-openrc rrsync::noarch"
source="https://download.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
rsyncd.initd
@@ -16,6 +18,13 @@ source="https://download.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
rsyncd.logrotate
"
+# secfixes:
+# 3.1.3-r2:
+# - CVE-2016-9840
+# - CVE-2016-9841
+# - CVE-2016-9842
+# - CVE-2016-9843
+
build() {
# Force IPv6 enabled, upstream bug https://bugzilla.samba.org/show_bug.cgi?id=10715
CFLAGS="$CFLAGS -DINET6" \
@@ -27,7 +36,8 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-acl-support \
- --enable-xattr-support
+ --enable-xattr-support \
+ --with-included-zlib=no
make
}