summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/zsh/APKBUILD5
-rw-r--r--system/zsh/zprofile2
2 files changed, 3 insertions, 4 deletions
diff --git a/system/zsh/APKBUILD b/system/zsh/APKBUILD
index a85083fc4..3bc96b226 100644
--- a/system/zsh/APKBUILD
+++ b/system/zsh/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=zsh
pkgver=5.7.1
-pkgrel=2
+pkgrel=3
pkgdesc="A very advanced and programmable command interpreter (shell)"
url="https://www.zsh.org/"
arch="all"
@@ -98,6 +98,7 @@ build() {
--enable-unicode9 \
--enable-multibyte \
--enable-function-subdirs \
+ --enable-zprofile=/etc/zsh/zprofile \
--enable-zsh-secure-free \
--with-tcsetpgrp
make
@@ -179,5 +180,5 @@ _submv() {
sha512sums="a6aa88e1955a80229a4784a128866e325f79a8b5f73c922ab480048411036f1835cbb31daa30ab38bd16ab2a50040eda8f4f1f64704b21b6acc3051b1dbf18d0 zsh-5.7.1.tar.xz
d820fcf65bb3c52f23e968110b5df1188fc0b64079312f64d22ffe35de3b4f3055d4d629b3b0f97a1bfaddf62dbc80676af31c3a1a79645632082abfc854cf97 skel
-e90723eb790581419498f3ab86fb5d6cab4aaede8c87eb79ead7047d259b643cfb47f4d1beb06d03e038cfda3a20ef9dd4c1b417270ab55c688e166fe30ef4f6 zprofile
+63167188e22bf8933eb420a5ba068ab897531b90c8d8b8ec892f26a9180267a971013046a72b810d5b9d3add427cf650df608b0e008cd0789681ed1371b172c3 zprofile
1675e016f97333cad89b587f4292d81b6bc10e27b75482e3e0c3808539c95bd49b907b6579fb98d817f77f2f2384c0df5afa3e2b6f43b6ae9b466925cd9ccffc zshrc"
diff --git a/system/zsh/zprofile b/system/zsh/zprofile
index 50cbdaaaa..df7a3f76e 100644
--- a/system/zsh/zprofile
+++ b/system/zsh/zprofile
@@ -2,8 +2,6 @@
# /etc/zprofile and ~/.zprofile are run for login shells
#
-export PATH="$PATH:$HOME/bin"
-
_src_etc_profile()
{
# Make /etc/profile happier, and have possible ~/.zshenv options like