summaryrefslogtreecommitdiff
path: root/user/alpine
diff options
context:
space:
mode:
Diffstat (limited to 'user/alpine')
-rw-r--r--user/alpine/APKBUILD19
-rw-r--r--user/alpine/support-musl.patch4
2 files changed, 10 insertions, 13 deletions
diff --git a/user/alpine/APKBUILD b/user/alpine/APKBUILD
index 189057dea..6023176f3 100644
--- a/user/alpine/APKBUILD
+++ b/user/alpine/APKBUILD
@@ -1,7 +1,7 @@
-# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=alpine
-pkgver=2.21
+pkgver=2.22
pkgrel=0
pkgdesc="Terminal-based email client"
url="http://alpine.x10host.com/alpine/"
@@ -9,19 +9,18 @@ arch="all"
license="Apache-2.0"
depends=""
makedepends="aspell-dev krb5-dev linux-pam-dev ncurses-dev openldap-dev
- openssl-dev"
+ openssl-dev autoconf automake libtool"
subpackages="$pkgname-doc"
source="http://alpine.x10host.com/alpine/release/src/alpine-$pkgver.tar.xz
- support-musl.patch"
+ support-musl.patch
+ "
prepare() {
- cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,14 +32,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="a2a36a033c8af79810816a7da7185c269808ba6d84d013691fd8b3764c63f5fb2284e6844ec5a5e99d168514ae636debf59fae962533a2916679e4e9109c6264 alpine-2.21.tar.xz
-cdf827b5947fd14b6a6c1ad86df4ff1b8be1ffd51279aaa02376b2b60f3de742c54364e18d73d9a75c5c87ed3c8668a3f0c9eb59733f8da195e85833b4364782 support-musl.patch"
+sha512sums="7737dce02ac94170948df7fccb61380c6cb101190e37f5b3ba281d573f54df1db24569d177b460f49bfff381a922be2e4b0f3a0f1a213d88a64d361aedc3c4f1 alpine-2.22.tar.xz
+f26aaac4f81762227254e913f15c18b444e89d92b6885d62755d673d1f3097a126d297dc655b619d91b83bf5645ed0b4d5454c74a95cc142cd5fe3cb391e81cd support-musl.patch"
diff --git a/user/alpine/support-musl.patch b/user/alpine/support-musl.patch
index ab3c2d857..a63a351d9 100644
--- a/user/alpine/support-musl.patch
+++ b/user/alpine/support-musl.patch
@@ -1,6 +1,6 @@
--- ./configure.ac.orig
+++ ./configure.ac
-@@ -723,7 +723,7 @@
+@@ -726,7 +726,7 @@
else
dnl preload c-client default locations/options
case $host in
@@ -9,7 +9,7 @@
if test -f /etc/fedora-release -o -f /etc/redhat-release -o -f /etc/redhat_version ; then
alpine_SSLTYPE="nopwd"
if test -d /etc/pki/tls ; then
-@@ -1059,7 +1059,7 @@
+@@ -1070,7 +1070,7 @@
dnl build from c-client. Most of this will go away when c-client
dnl adopts configure
case "$host" in