summaryrefslogtreecommitdiff
path: root/user/alpine
diff options
context:
space:
mode:
Diffstat (limited to 'user/alpine')
-rw-r--r--user/alpine/APKBUILD14
-rw-r--r--user/alpine/support-musl.patch20
2 files changed, 3 insertions, 31 deletions
diff --git a/user/alpine/APKBUILD b/user/alpine/APKBUILD
index 6023176f3..2ac0989d2 100644
--- a/user/alpine/APKBUILD
+++ b/user/alpine/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=alpine
-pkgver=2.22
+pkgver=2.23
pkgrel=0
pkgdesc="Terminal-based email client"
url="http://alpine.x10host.com/alpine/"
@@ -11,14 +11,7 @@ depends=""
makedepends="aspell-dev krb5-dev linux-pam-dev ncurses-dev openldap-dev
openssl-dev autoconf automake libtool"
subpackages="$pkgname-doc"
-source="http://alpine.x10host.com/alpine/release/src/alpine-$pkgver.tar.xz
- support-musl.patch
- "
-
-prepare() {
- default_prepare
- autoreconf -vif
-}
+source="http://alpine.x10host.com/alpine/release/src/alpine-$pkgver.tar.xz"
build() {
./configure \
@@ -39,5 +32,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="7737dce02ac94170948df7fccb61380c6cb101190e37f5b3ba281d573f54df1db24569d177b460f49bfff381a922be2e4b0f3a0f1a213d88a64d361aedc3c4f1 alpine-2.22.tar.xz
-f26aaac4f81762227254e913f15c18b444e89d92b6885d62755d673d1f3097a126d297dc655b619d91b83bf5645ed0b4d5454c74a95cc142cd5fe3cb391e81cd support-musl.patch"
+sha512sums="abc3675b18d6bd20a547b8e2c3f1f4c668aee2f2d20f426f28b4b3d4cfd66762777007441da3b0fda74e625c71bc2ef05434089508c2af804e62cf216df5554b alpine-2.23.tar.xz"
diff --git a/user/alpine/support-musl.patch b/user/alpine/support-musl.patch
deleted file mode 100644
index a63a351d9..000000000
--- a/user/alpine/support-musl.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./configure.ac.orig
-+++ ./configure.ac
-@@ -726,7 +726,7 @@
- else
- dnl preload c-client default locations/options
- case $host in
-- *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*)
-+ *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*|*-linux-musl*)
- if test -f /etc/fedora-release -o -f /etc/redhat-release -o -f /etc/redhat_version ; then
- alpine_SSLTYPE="nopwd"
- if test -d /etc/pki/tls ; then
-@@ -1070,7 +1070,7 @@
- dnl build from c-client. Most of this will go away when c-client
- dnl adopts configure
- case "$host" in
-- *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*)
-+ *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*|*-linux-musl*)
- alpine_path_delim="/"
- alpine_mode_readonly="(0600)"
- if test -f /etc/fedora-release ; then