summaryrefslogtreecommitdiff
path: root/user/apache-httpd
diff options
context:
space:
mode:
Diffstat (limited to 'user/apache-httpd')
-rw-r--r--user/apache-httpd/APKBUILD2
-rw-r--r--user/apache-httpd/apache-httpd.pre-install8
l---------[-rw-r--r--]user/apache-httpd/apache-httpd.pre-upgrade9
3 files changed, 6 insertions, 13 deletions
diff --git a/user/apache-httpd/APKBUILD b/user/apache-httpd/APKBUILD
index fb5e75d29..90a098922 100644
--- a/user/apache-httpd/APKBUILD
+++ b/user/apache-httpd/APKBUILD
@@ -3,7 +3,7 @@
pkgname=apache-httpd
_pkgreal=httpd
pkgver=2.4.39
-pkgrel=0
+pkgrel=1
pkgdesc="Open-source HTTP server"
url="https://httpd.apache.org"
arch="all"
diff --git a/user/apache-httpd/apache-httpd.pre-install b/user/apache-httpd/apache-httpd.pre-install
index d4ede7476..49adfaab7 100644
--- a/user/apache-httpd/apache-httpd.pre-install
+++ b/user/apache-httpd/apache-httpd.pre-install
@@ -1,8 +1,8 @@
#!/bin/sh
-addgroup -S -g 82 www-data 2>/dev/null
-addgroup -S apache 2>/dev/null
-adduser -S -D -H -h /var/www -s /sbin/nologin -G apache -g apache apache 2>/dev/null
-addgroup apache www-data 2>/dev/null
+groupadd -r -g 82 www-data 2>/dev/null
+groupadd -r apache 2>/dev/null
+useradd -c apache -s /sbin/nologin -g apache -G www-data \
+ -m -d /var/www -k /etc/skel -r apache 2>/dev/null
exit 0
diff --git a/user/apache-httpd/apache-httpd.pre-upgrade b/user/apache-httpd/apache-httpd.pre-upgrade
index d4ede7476..02edc914c 100644..120000
--- a/user/apache-httpd/apache-httpd.pre-upgrade
+++ b/user/apache-httpd/apache-httpd.pre-upgrade
@@ -1,8 +1 @@
-#!/bin/sh
-
-addgroup -S -g 82 www-data 2>/dev/null
-addgroup -S apache 2>/dev/null
-adduser -S -D -H -h /var/www -s /sbin/nologin -G apache -g apache apache 2>/dev/null
-addgroup apache www-data 2>/dev/null
-
-exit 0
+apache-httpd.pre-install \ No newline at end of file