summaryrefslogtreecommitdiff
path: root/user/aspell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/aspell/APKBUILD')
-rw-r--r--user/aspell/APKBUILD69
1 files changed, 69 insertions, 0 deletions
diff --git a/user/aspell/APKBUILD b/user/aspell/APKBUILD
new file mode 100644
index 000000000..a2cc79f32
--- /dev/null
+++ b/user/aspell/APKBUILD
@@ -0,0 +1,69 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer:
+pkgname=aspell
+pkgver=0.60.6.1
+pkgrel=13
+pkgdesc="Libre spell checker software"
+url="http://aspell.net/"
+arch="all"
+license="LGPL-2.0+"
+subpackages="$pkgname-compat::noarch $pkgname-utils $pkgname-dev $pkgname-doc
+ $pkgname-lang $pkgname-libs"
+depends=
+depends_dev="$pkgname-utils"
+makedepends="ncurses-dev perl"
+install=
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ LIBS="-ltinfo" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-dict-dir=/usr/share/$pkgname \
+ --enable-pkgdatadir=/usr/share/$pkgname \
+ --enable-compile-in-filters
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+compat() {
+ pkgdesc="aspell compatibility scripts for ispell and unix spell"
+ depends="$pkgname"
+ install -d "$subpkgdir"/usr/bin
+ cd "$pkgdir"/usr/share/$pkgname
+ mv spell ispell "$subpkgdir"/usr/bin/
+}
+
+utils() {
+ pkgdesc="Utilities for aspell"
+ depends="$pkgname perl"
+ install -d "$subpkgdir"/usr/bin
+ cd "$pkgdir"/usr/bin
+ mv pre* aspell-import run-with-aspell word-list-compress "$subpkgdir"/usr/bin/
+}
+
+libs() {
+ default_libs
+ mv "$pkgdir"/usr/share "$subpkgdir"/usr
+ rm -fr "$pkgdir"/usr/lib
+}
+
+sha512sums="f310c7590be98406589b5c26ca36a2ecfe4733f0b40fd6c176b96b7955ef2b5cd0ec9a3d770cf132146ae7a896042b4b698945112995ee1ae66adcfa5542247f aspell-0.60.6.1.tar.gz"