summaryrefslogtreecommitdiff
path: root/user/bluez
diff options
context:
space:
mode:
Diffstat (limited to 'user/bluez')
-rw-r--r--user/bluez/APKBUILD74
-rw-r--r--user/bluez/bluez-5.40-obexd_without_systemd-1.patch61
-rw-r--r--user/bluez/dbus-without-systemd.patch34
-rw-r--r--user/bluez/mesh-without-systemd.patch29
-rw-r--r--user/bluez/obex-without-systemd.patch54
-rw-r--r--user/bluez/time64.patch82
6 files changed, 252 insertions, 82 deletions
diff --git a/user/bluez/APKBUILD b/user/bluez/APKBUILD
index 35e98e08b..af4f09ba8 100644
--- a/user/bluez/APKBUILD
+++ b/user/bluez/APKBUILD
@@ -1,43 +1,63 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=bluez
-pkgver=5.51
-pkgrel=0
+pkgver=5.53
+pkgrel=1
pkgdesc="Linux Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
license="GPL-2.0+"
depends="consolekit2 dbus"
makedepends="alsa-lib-dev dbus-dev eudev-dev glib-dev libical-dev
- linux-headers"
+ linux-headers ncurses-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bccmd
$pkgname-btmon $pkgname-cups $pkgname-deprecated $pkgname-hid2hci
- $pkgname-obexd $pkgname-openrc"
+ $pkgname-obexd $pkgname-openrc $pkgname-tools"
source="https://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
+ https://ftp.gnu.org/gnu/readline/readline-8.0.tar.gz
bluetooth.initd
rfcomm.initd
rfcomm.confd
- 001-bcm43xx-Add-bcm43xx-3wire-variant.patch
- 002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
- 003-Increase-firmware-load-timeout-to-30s.patch
- 004-Move-the-43xx-firmware-into-lib-firmware.patch
- bluez-5.40-obexd_without_systemd-1.patch
+ 001-bcm43xx-Add-bcm43xx-3wire-variant.patch
+ 002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
+ 003-Increase-firmware-load-timeout-to-30s.patch
+ 004-Move-the-43xx-firmware-into-lib-firmware.patch
+ dbus-without-systemd.patch
+ mesh-without-systemd.patch
+ obex-without-systemd.patch
disable-lock-test.patch
fix-endianness.patch
+ time64.patch
"
-build() {
+prepare() {
+ default_prepare
+
+ cd "$srcdir"/readline-8.0
./configure \
--build=$CBUILD \
--host=$CHOST \
+ --prefix="$srcdir"/readline \
+ --enable-static \
+ --disable-shared
+ make install
+}
+
+build() {
+ CFLAGS="$CFLAGS -I$srcdir/readline/include -L$srcdir/readline/lib" \
+ CPPFLAGS="$CPPFLAGS -I$srcdir/readline/include" LIBS="-ltinfo" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--libexecdir=/usr/lib \
--disable-systemd \
- --disable-client \
+ --enable-client \
--enable-library \
- --enable-deprecated
+ --enable-deprecated \
+ --enable-experimental \
+ --enable-tools
make
}
@@ -56,33 +76,33 @@ package() {
}
bccmd() {
- pkgdesc="Bluez utility for the CSR BCCMD interface"
+ pkgdesc="BlueZ utility for the CSR BCCMD interface"
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/bccmd "$subpkgdir"/usr/bin/
}
btmon() {
- pkgdesc="Bluez bluetooth monitor"
+ pkgdesc="BlueZ Bluetooth monitor"
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/btmon "$subpkgdir"/usr/bin/
}
cups() {
- pkgdesc="Bluez backend for CUPS"
+ pkgdesc="BlueZ backend for CUPS"
depends="cups"
mkdir -p "$subpkgdir"/usr/lib/
mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
}
hid2hci() {
- pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
+ pkgdesc="Put HID proxying Bluetooth HCIs into HCI mode"
replaces="bluez"
mkdir -p "$subpkgdir"
mv "$pkgdir"/lib "$subpkgdir"/
}
deprecated() {
- pkgdesc="Deprecated bluetooth tools"
+ pkgdesc="Deprecated Bluetooth tools"
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/ciptool \
"$pkgdir"/usr/bin/hciattach \
@@ -95,12 +115,21 @@ deprecated() {
}
obexd() {
- pkgdesc="Bluez OBEX daemon"
+ pkgdesc="BlueZ OBEX daemon"
mkdir -p "$subpkgdir"/usr/lib/bluetooth
mv "$pkgdir"/usr/lib/bluetooth/obexd "$subpkgdir"/usr/lib/bluetooth
}
-sha512sums="8b14eea98f541b981162abce728e0f917654ad3c990721ec398fe41bdd68069fe55ff64b61bc3c3b9f813facf42c995b07619f6d5d153965de27154b1a7b578f bluez-5.51.tar.xz
+tools() {
+ pkgdesc="Bluetooth tools"
+ mkdir -p "$subpkgdir"/usr/bin
+ for _tool in bluetooth-player mpris-proxy; do
+ install -Dm755 "$builddir"/tools/$_tool "$subpkgdir"/usr/bin/$_tool
+ done
+}
+
+sha512sums="62956e6293ec2517ec453dc7a6c82d34a8c446df8add8fe411b0a45fd5604817f3a19fbc646ad6f68df435f3cd2bd10ae040890e30db83b022f90b54cc6b3c74 bluez-5.53.tar.xz
+41759d27bc3a258fefd7f4ff3277fa6ab9c21abb7b160e1a75aa8eba547bd90b288514e76264bd94fb0172da8a4faa54aab2c07b68a0356918ecf7f1969e866f readline-8.0.tar.gz
fc43c78ed248ea412529eed5ae8bb47bacca9bf5b3b10de121ddd4e792c85893561a88be4aa2c6318106e5d2146a721445152d44fa60ca257ca0b4eb87318c1e bluetooth.initd
8d7b7c8938a2316ce0a855e9bdf1ef8fcdf33d23f4011df828270a088b88b140a19c432e83fef15355d0829e3c86be05b63e7718fef88563254ea239b8dc12ac rfcomm.initd
a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd
@@ -108,6 +137,9 @@ a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b34841
d5fd1c962bd846eaa6fff879bab85f753eb367d514f82d133b5d3242e1da989af5eddd942c60a87d5b67783e060f91bfa0f74fb1e8e6699cdee6e5bbe6a431ea 002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
784e9644c8de4e2693e2eeed988a245608b8cb14e1fc0dff8795c60c527b2e8d0c87862cfbfd6b850b47ae80cdf993a5ed3f477078ea1068fd7374899c7a1a77 003-Increase-firmware-load-timeout-to-30s.patch
42ac04044a8c66e07487598b3a75ef52efc32999ebce4e7c63f6198e2f603f4a1442e74600e43a0938cb4f52d4db0298aa99050b18144b84990cda71748e9de5 004-Move-the-43xx-firmware-into-lib-firmware.patch
-b7640a78cb33b3628564ebb2d8bcaf4255bddf5a25068838a9cc5fbd26d5d8dbf51e4b6b6fd2137fccae593482b2927ba13cb166be255be02d72a245ea60c3ff bluez-5.40-obexd_without_systemd-1.patch
+a681a98178f9374ab882984058559752d1e1f3261412f450b38f1a06c3dfb5ce45e2cce35aa152f3c5761a9f7695fb0990cfdcc394706304470e6d1a8dbef682 dbus-without-systemd.patch
+59fa8b90d5b8ac5922b730b01fbeb8a237075cd537705fe2665f15c7626bc6a8bd8128a3e899b0c620b6cb4f86862c2a416b2af8c2575d0724b26c8132aff251 mesh-without-systemd.patch
+9aa78fdd9a84dd2a20cd6a4f5105e88af16896ae81a76a9a9f86902a9988d58af1102948c2d87397df36d747ce206d06a7bf1795c3ceb6a4617d95a26be3526f obex-without-systemd.patch
04c4889372c8e790bb338dde7ffa76dc32fcf7370025c71b9184fcf17fd01ade4a6613d84d648303af3bbc54043ad489f29fc0cd4679ec8c9029dcb846d7e026 disable-lock-test.patch
-118d55183860f395fc4bdc93efffb13902ebf7388cad722b9061cd2860d404333e500af521741c3d92c0f8a161f6810348fbeb6682e49c372383f417aed8c76a fix-endianness.patch"
+118d55183860f395fc4bdc93efffb13902ebf7388cad722b9061cd2860d404333e500af521741c3d92c0f8a161f6810348fbeb6682e49c372383f417aed8c76a fix-endianness.patch
+da2ca90b0de1afb90914370dbc482f78ab9a270e60142ed7901eff408d02611d7fe423ae4677bce49fe829d59aa9aa971f9d0039d6e9134d3346aeb51b62ba9c time64.patch"
diff --git a/user/bluez/bluez-5.40-obexd_without_systemd-1.patch b/user/bluez/bluez-5.40-obexd_without_systemd-1.patch
deleted file mode 100644
index 17433fccd..000000000
--- a/user/bluez/bluez-5.40-obexd_without_systemd-1.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Submitted By: Armin K. <krejzi at email dot com>
-Date: 2013-04-29
-Initial Package Version: 5.17
-Upstream Status: unknown
-Origin: Arch Linux (Giovanni Campagna)
-Description: Allow using obexd without systemd in the user session
-
-Not all sessions run systemd --user (actually, the majority
-doesn't), so the dbus daemon must be able to spawn obexd
-directly, and to do so it needs the full path of the daemon.
----
- Makefile.obexd | 4 ++--
- obexd/src/org.bluez.obex.service | 4 ----
- obexd/src/org.bluez.obex.service.in | 4 ++++
- 3 files changed, 6 insertions(+), 6 deletions(-)
- delete mode 100644 obexd/src/org.bluez.obex.service
- create mode 100644 obexd/src/org.bluez.obex.service.in
-
-diff --git a/Makefile.obexd b/Makefile.obexd
-index 3760867..142e7c3 100644
---- a/Makefile.obexd
-+++ b/Makefile.obexd
-@@ -1,12 +1,12 @@
- if SYSTEMD
- systemduserunitdir = $(SYSTEMD_USERUNITDIR)
- systemduserunit_DATA = obexd/src/obex.service
-+endif
-
- dbussessionbusdir = $(DBUS_SESSIONBUSDIR)
- dbussessionbus_DATA = obexd/src/org.bluez.obex.service
--endif
-
--EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service
-+EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in
-
- obex_plugindir = $(libdir)/obex/plugins
-
-diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service
-deleted file mode 100644
-index a538088..0000000
---- a/obexd/src/org.bluez.obex.service
-+++ /dev/null
-@@ -1,4 +0,0 @@
--[D-BUS Service]
--Name=org.bluez.obex
--Exec=/bin/false
--SystemdService=dbus-org.bluez.obex.service
-diff --git a/obexd/src/org.bluez.obex.service.in b/obexd/src/org.bluez.obex.service.in
-new file mode 100644
-index 0000000..9c815f2
---- /dev/null
-+++ b/obexd/src/org.bluez.obex.service.in
-@@ -0,0 +1,4 @@
-+[D-BUS Service]
-+Name=org.bluez.obex
-+Exec=@libexecdir@/obexd
-+SystemdService=dbus-org.bluez.obex.service
---
-1.8.3.1
-
-
diff --git a/user/bluez/dbus-without-systemd.patch b/user/bluez/dbus-without-systemd.patch
new file mode 100644
index 000000000..5b9c7dc70
--- /dev/null
+++ b/user/bluez/dbus-without-systemd.patch
@@ -0,0 +1,34 @@
+From 2625ab38ae27754205d060f09e3a18f7648d5167 Mon Sep 17 00:00:00 2001
+From: Doan Tran Cong Danh <congdanhqx@gmail.com>
+Date: Thu, 3 Oct 2019 12:57:09 +0700
+Subject: [PATCH 1/9] enable dbus without systemd
+
+---
+ Makefile.am | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 404e6a460..0884156fa 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -40,14 +40,14 @@ conf_DATA =
+
+ statedir = $(localstatedir)/lib/bluetooth
+ state_DATA =
++
++dbussystembusdir = $(DBUS_SYSTEMBUSDIR)
++dbussystembus_DATA = src/org.bluez.service
+ endif
+
+ if SYSTEMD
+ systemdsystemunitdir = $(SYSTEMD_SYSTEMUNITDIR)
+ systemdsystemunit_DATA = src/bluetooth.service
+-
+-dbussystembusdir = $(DBUS_SYSTEMBUSDIR)
+-dbussystembus_DATA = src/org.bluez.service
+ endif
+
+ EXTRA_DIST += src/bluetooth.service.in src/org.bluez.service
+--
+2.23.0
+
diff --git a/user/bluez/mesh-without-systemd.patch b/user/bluez/mesh-without-systemd.patch
new file mode 100644
index 000000000..2cf6f7344
--- /dev/null
+++ b/user/bluez/mesh-without-systemd.patch
@@ -0,0 +1,29 @@
+From 32a425c3f9b42a55824c044a6b486c9c12e65a65 Mon Sep 17 00:00:00 2001
+From: Doan Tran Cong Danh <congdanhqx@gmail.com>
+Date: Thu, 3 Oct 2019 12:58:18 +0700
+Subject: [PATCH 3/9] allow mesh on non-systemd system
+
+---
+ Makefile.mesh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.mesh b/Makefile.mesh
+index 90979cbc0..9e6e2c2ca 100644
+--- a/Makefile.mesh
++++ b/Makefile.mesh
+@@ -2,11 +2,11 @@ if MESH
+
+ if DATAFILES
+ dbus_DATA += mesh/bluetooth-mesh.conf
++dbussystembus_DATA += mesh/org.bluez.mesh.service
+ endif
+
+ if SYSTEMD
+ systemdsystemunit_DATA += mesh/bluetooth-mesh.service
+-dbussystembus_DATA += mesh/org.bluez.mesh.service
+ endif
+
+ mesh_sources = mesh/mesh.h mesh/mesh.c \
+--
+2.23.0
+
diff --git a/user/bluez/obex-without-systemd.patch b/user/bluez/obex-without-systemd.patch
new file mode 100644
index 000000000..c011d2307
--- /dev/null
+++ b/user/bluez/obex-without-systemd.patch
@@ -0,0 +1,54 @@
+From 5f27d3887b60c95cbcdefaeae5dea38f020c390e Mon Sep 17 00:00:00 2001
+From: Doan Tran Cong Danh <congdanhqx@gmail.com>
+Date: Thu, 3 Oct 2019 12:57:55 +0700
+Subject: [PATCH 2/8] allow obexd on non-systemd system
+
+---
+ Makefile.obexd | 6 +++---
+ .../{org.bluez.obex.service => org.bluez.obex.service.in} | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+ rename obexd/src/{org.bluez.obex.service => org.bluez.obex.service.in} (74%)
+
+diff --git a/Makefile.obexd b/Makefile.obexd
+index de59d297b..cb04bb1e2 100644
+--- a/Makefile.obexd
++++ b/Makefile.obexd
+@@ -1,12 +1,12 @@
+ if SYSTEMD
+ systemduserunitdir = $(SYSTEMD_USERUNITDIR)
+ systemduserunit_DATA = obexd/src/obex.service
++endif
+
+ dbussessionbusdir = $(DBUS_SESSIONBUSDIR)
+ dbussessionbus_DATA = obexd/src/org.bluez.obex.service
+-endif
+
+-EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service
++EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in
+
+ if OBEX
+
+@@ -107,6 +107,6 @@ obexd/src/builtin.h: obexd/src/genbuiltin $(obexd_builtin_sources)
+ $(AM_V_at)$(MKDIR_P) $(dir $@)
+ $(AM_V_GEN)$(srcdir)/obexd/src/genbuiltin $(obexd_builtin_modules) > $@
+
+-CLEANFILES += obexd/src/builtin.h $(builtin_files) obexd/src/obex.service
++CLEANFILES += obexd/src/builtin.h $(builtin_files) obexd/src/obex.service obexd/src/org.bluez.obex.service
+
+ EXTRA_DIST += obexd/src/genbuiltin
+diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service.in
+similarity index 74%
+rename from obexd/src/org.bluez.obex.service
+rename to obexd/src/org.bluez.obex.service.in
+index a53808884..543d7bc07 100644
+--- a/obexd/src/org.bluez.obex.service
++++ b/obexd/src/org.bluez.obex.service.in
+@@ -1,4 +1,4 @@
+ [D-BUS Service]
+ Name=org.bluez.obex
+-Exec=/bin/false
++Exec=@pkglibexecdir@/obexd
+ SystemdService=dbus-org.bluez.obex.service
+--
+2.23.0
+
diff --git a/user/bluez/time64.patch b/user/bluez/time64.patch
new file mode 100644
index 000000000..782255817
--- /dev/null
+++ b/user/bluez/time64.patch
@@ -0,0 +1,82 @@
+--- bluez-5.53/monitor/packet.c.old 2020-02-15 18:33:56.000000000 +0000
++++ bluez-5.53/monitor/packet.c 2020-02-25 09:24:09.629224611 +0000
+@@ -364,7 +364,7 @@
+ }
+
+ if (filter_mask & PACKET_FILTER_SHOW_TIME) {
+- n = sprintf(ts_str + ts_pos, " %02d:%02d:%02d.%06lu",
++ n = sprintf(ts_str + ts_pos, " %02d:%02d:%02d.%06"PRIu64,
+ tm.tm_hour, tm.tm_min, tm.tm_sec, tv->tv_usec);
+ if (n > 0) {
+ ts_pos += n;
+@@ -373,7 +373,7 @@
+ }
+
+ if (filter_mask & PACKET_FILTER_SHOW_TIME_OFFSET) {
+- n = sprintf(ts_str + ts_pos, " %lu.%06lu",
++ n = sprintf(ts_str + ts_pos, " %"PRIu64".%06"PRIu64,
+ tv->tv_sec - time_offset, tv->tv_usec);
+ if (n > 0) {
+ ts_pos += n;
+--- bluez-5.53/tools/parser/parser.h.old 2015-10-30 03:30:13.000000000 +0000
++++ bluez-5.53/tools/parser/parser.h 2020-02-25 09:26:51.471579651 +0000
+@@ -26,6 +26,7 @@
+ #define __PARSER_H
+
+ #include <time.h>
++#include <inttypes.h>
+ #include <sys/time.h>
+ #include <netinet/in.h>
+
+@@ -133,11 +134,11 @@
+ struct tm tm;
+ time_t t = f->ts.tv_sec;
+ localtime_r(&t, &tm);
+- printf("%04d-%02d-%02d %02d:%02d:%02d.%06lu ",
++ printf("%04d-%02d-%02d %02d:%02d:%02d.%06"PRIu64" ",
+ tm.tm_year + 1900, tm.tm_mon + 1, tm.tm_mday,
+ tm.tm_hour, tm.tm_min, tm.tm_sec, f->ts.tv_usec);
+ } else
+- printf("%8lu.%06lu ", f->ts.tv_sec, f->ts.tv_usec);
++ printf("%8"PRIu64".%06"PRIu64" ", f->ts.tv_sec, f->ts.tv_usec);
+ }
+ printf("%c ", (f->in ? '>' : '<'));
+ parser.state = 1;
+--- bluez-5.53/tools/rctest.c.old 2019-09-19 18:51:03.000000000 +0000
++++ bluez-5.53/tools/rctest.c 2020-02-25 09:24:56.994060632 +0000
+@@ -36,6 +36,7 @@
+ #include <getopt.h>
+ #include <syslog.h>
+ #include <signal.h>
++#include <inttypes.h>
+ #include <sys/time.h>
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
+@@ -513,7 +514,7 @@
+ timestamp = 0;
+ memset(ts, 0, sizeof(ts));
+ } else {
+- sprintf(ts, "[%ld.%ld] ",
++ sprintf(ts, "[%"PRId64".%"PRId64"] ",
+ tv.tv_sec, tv.tv_usec);
+ }
+ }
+--- bluez-5.53/tools/l2test.c.old 2019-09-19 18:51:03.000000000 +0000
++++ bluez-5.53/tools/l2test.c 2020-02-25 09:27:47.325490145 +0000
+@@ -38,6 +38,7 @@
+ #include <getopt.h>
+ #include <syslog.h>
+ #include <signal.h>
++#include <inttypes.h>
+ #include <sys/time.h>
+ #include <poll.h>
+ #include <sys/ioctl.h>
+@@ -915,7 +916,7 @@
+ timestamp = 0;
+ memset(ts, 0, sizeof(ts));
+ } else {
+- sprintf(ts, "[%ld.%ld] ",
++ sprintf(ts, "[%"PRId64".%"PRId64"] ",
+ tv.tv_sec, tv.tv_usec);
+ }
+ }