summaryrefslogtreecommitdiff
path: root/user/compton
diff options
context:
space:
mode:
Diffstat (limited to 'user/compton')
-rw-r--r--user/compton/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/compton/APKBUILD b/user/compton/APKBUILD
new file mode 100644
index 000000000..338f123de
--- /dev/null
+++ b/user/compton/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=compton
+pkgver=4
+pkgrel=0
+pkgdesc="Lightweight compositor for X11"
+url="https://github.com/yshui/compton"
+arch="all"
+options="!check" # no tests
+license="MIT AND MPL-2.0"
+makedepends="meson libx11-dev libxext-dev libev-dev xcb-util-renderutil-dev
+ xcb-util-image-dev pixman-dev libconfig-dev pcre-dev mesa-dev
+ dbus-dev"
+source="compton-$pkgver.tar.gz::https://github.com/yshui/compton/archive/v$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="ba585df25792519b8093a5a91d62ca2d3b02dd9df41d787dc4007cee5c8aef7cd0a3c267b58d21026c97b7859f7c5376384dffb7da728a99ccc4122a2ae43679 compton-4.tar.gz"