summaryrefslogtreecommitdiff
path: root/user/gitlab-runner/gccgo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/gitlab-runner/gccgo.patch')
-rw-r--r--user/gitlab-runner/gccgo.patch55
1 files changed, 26 insertions, 29 deletions
diff --git a/user/gitlab-runner/gccgo.patch b/user/gitlab-runner/gccgo.patch
index 106a36a42..bd0b7a3d5 100644
--- a/user/gitlab-runner/gccgo.patch
+++ b/user/gitlab-runner/gccgo.patch
@@ -12,48 +12,45 @@
BUILT := $(shell date -u +%Y-%m-%dT%H:%M:%S%z)
-export TESTFLAGS ?= -cover
- LATEST_STABLE_TAG := $(shell git -c versionsort.prereleaseSuffix="-rc" -c versionsort.prereleaseSuffix="-RC" tag -l "v*.*.*" --sort=-v:refname | awk '!/rc/' | head -n 1)
+ LATEST_STABLE_TAG := $(shell git -c versionsort.prereleaseSuffix="-rc" -c versionsort.prereleaseSuffix="-RC" tag -l "v*.*.*" | sort -rV | awk '!/rc/' | head -n 1)
export IS_LATEST :=
-@@ -36,14 +35,11 @@ export PATH := $(GOPATH_BIN):$(PATH)
+@@ -35,14 +34,11 @@ export PATH := $(GOPATH_BIN):$(PATH)
+ BUILD_DIR := $(CURDIR)
+ TARGET_DIR := $(BUILD_DIR)/out
- # Packages in vendor/ are included in ./...
- # https://github.com/golang/go/issues/11659
--export OUR_PACKAGES ?= $(subst _$(BUILD_DIR),$(PKG),$(shell go list ./... | grep -v '/vendor/'))
-+export OUR_PACKAGES ?= $(subst _$(BUILD_DIR),$(PKG),$(shell go list ./... | grep -ve '/vendor/' -e '/cache/gcs' -e '/cache/s3' -e '/docker' -e '/kubernetes' -e '/parallels' -e '/virtualbox'))
+ export MAIN_PACKAGE ?= gitlab.com/gitlab-org/gitlab-runner
-GO_LDFLAGS ?= -X $(COMMON_PACKAGE_NAMESPACE).NAME=$(PACKAGE_NAME) -X $(COMMON_PACKAGE_NAMESPACE).VERSION=$(VERSION) \
- -X $(COMMON_PACKAGE_NAMESPACE).REVISION=$(REVISION) -X $(COMMON_PACKAGE_NAMESPACE).BUILT=$(BUILT) \
- -X $(COMMON_PACKAGE_NAMESPACE).BRANCH=$(BRANCH) \
-- -s -w
-+GO_LDFLAGS ?= -s -w
+- -w
++GO_LDFLAGS ?= -w
GO_FILES ?= $(shell find . -name '*.go')
-export CGO_ENABLED ?= 0
+export CGO_ENABLED ?= 1
# Development Tools
-@@ -112,7 +108,7 @@ build_current: helper-docker build_simpl
- check_race_conditions:
- @./scripts/check_race_conditions $(OUR_PACKAGES)
-
--test: helper-docker development_setup simple-test
-+test: simple-test
-
+@@ -136,7 +132,7 @@ build_current: helper-docker build_simpl
+ simple-test: TEST_PKG ?= $(shell go list ./...)
simple-test:
- go test $(OUR_PACKAGES) $(TESTFLAGS)
+ # use env -i to clear parent environment variables for go test
+- ./scripts/go_test_no_env $(TEST_PKG) $(TESTFLAGS) -ldflags "$(GO_LDFLAGS)"
++ ./scripts/go_test_no_env $(TEST_PKG) $(TESTFLAGS) -gccgoflags "$(GO_LDFLAGS)"
+
+ git1.8-test: export TEST_PKG = gitlab.com/gitlab-org/gitlab-runner/executors/shell gitlab.com/gitlab-org/gitlab-runner/shells
+ git1.8-test:
--- gitlab-runner-v13.0.0/Makefile.build.mk.old 2020-05-20 03:10:39.000000000 -0500
+++ gitlab-runner-v13.0.0/Makefile.build.mk 2024-05-30 22:18:11.590776424 -0500
-@@ -9,8 +9,8 @@
-
- build_simple:
- # Building $(NAME) in version $(VERSION) for current platform
-- go build \
-- -ldflags "$(GO_LDFLAGS)" \
+@@ -1,6 +1,5 @@
+ runner-bin: $(GOX)
+ # Building $(NAME) in version $(VERSION) for $(BUILD_PLATFORMS)
+- $(GOX) $(BUILD_PLATFORMS) \
+- -ldflags "$(GO_LDFLAGS)" \
+- -output="out/binaries/$(NAME)-{{.OS}}-{{.Arch}}" \
+ go build -v \
-+ -gccgoflags "$(GO_LDFLAGS)" \
- -o "$(RUNNER_BINARY)" \
- $(PKG)
-
++ -gccgoflags "$(GO_LDFLAGS)" \
+ $(PKG)
--- gitlab-runner-v12.1.0/common/version.go 2019-07-19 12:13:32.000000000 +0000
+++ gitlab-runner-v12.1.0/common/version.go 2020-04-27 00:57:04.923408027 +0000
@@ -9,9 +9,9 @@ import (
@@ -63,9 +60,9 @@
-var VERSION = "development version"
-var REVISION = "HEAD"
-var BRANCH = "HEAD"
-+var VERSION = "13.0.0"
-+var REVISION = "v13.0.0"
-+var BRANCH = "13-0-stable"
++var VERSION = "14.0.0"
++var REVISION = "v14.0.0"
++var BRANCH = "14-0-stable"
var BUILT = "unknown"
var AppVersion AppVersionInfo