summaryrefslogtreecommitdiff
path: root/user/guile/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/guile/APKBUILD')
-rw-r--r--user/guile/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/user/guile/APKBUILD b/user/guile/APKBUILD
index 7d1d1c960..871131af0 100644
--- a/user/guile/APKBUILD
+++ b/user/guile/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=guile
pkgver=2.2.7
-pkgrel=0
+pkgrel=1
pkgdesc="Portable, embeddable Scheme implementation written in C"
url="https://www.gnu.org/software/guile/"
-arch="all !ppc" # https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26854
+arch="all"
options="!check !dbg !strip" # Requires actual LC_COLLATE and LC_MONETARY support.
license="LGPL-3.0+ AND GPL-3.0+"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
@@ -16,6 +16,14 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch
"
+prepare() {
+ default_prepare
+
+ case "$CARCH" in
+ ppc) rm -fvr prebuilt/32-bit-big-endian; ;; #533
+ esac
+}
+
build() {
./configure \
--build=$CBUILD \