summaryrefslogtreecommitdiff
path: root/user/hunspell
diff options
context:
space:
mode:
Diffstat (limited to 'user/hunspell')
-rw-r--r--user/hunspell/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/user/hunspell/APKBUILD b/user/hunspell/APKBUILD
index 6222d58a5..79da8d619 100644
--- a/user/hunspell/APKBUILD
+++ b/user/hunspell/APKBUILD
@@ -6,18 +6,17 @@ pkgdesc="Spell checker and morphological analyzer library and program"
url="https://hunspell.github.io/"
arch="all"
license="GPL-2.0+ AND LGPL-2.0+ AND MPL-1.1"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends=""
makedepends="ncurses-dev autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/hunspell/hunspell/archive/v$pkgver.tar.gz"
prepare() {
- cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
LIBS="-ltinfo" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}