summaryrefslogtreecommitdiff
path: root/user/kate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/kate/APKBUILD')
-rw-r--r--user/kate/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/user/kate/APKBUILD b/user/kate/APKBUILD
index ae31b0430..26afe3227 100644
--- a/user/kate/APKBUILD
+++ b/user/kate/APKBUILD
@@ -71,7 +71,7 @@ kwrite_doc() {
pkgdesc="Simple GUI text editor (documentation)"
install_if="docs kwrite=$pkgver-r$pkgrel"
for _langpath in "$pkgdir"/usr/share/doc/HTML/*; do
- local _sublangpath=${_langpath/"$pkgdir"/"$subpkgdir"}
+ local _sublangpath="$subpkgdir/${_langpath#"$pkgdir"}"
if [ -d "$_langpath"/kwrite ]; then
mkdir -p "$_sublangpath"
mv "$_langpath"/kwrite "$_sublangpath"/
@@ -84,7 +84,7 @@ kwrite_lang() {
pkgdesc="Simple GUI text editor (translations)"
for _langpath in "$pkgdir"/usr/share/locale/*/LC_MESSAGES; do
- local _sublangpath=${_langpath/"$pkgdir"/"$subpkgdir"}
+ local _sublangpath="$subpkgdir/${_langpath#"$pkgdir"}"
if [ -f "$_langpath"/kwrite.mo ]; then
mkdir -p "$_sublangpath"
mv "$_langpath"/kwrite.mo "$_sublangpath"/