summaryrefslogtreecommitdiff
path: root/user/kcompletion/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/kcompletion/APKBUILD')
-rw-r--r--user/kcompletion/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/user/kcompletion/APKBUILD b/user/kcompletion/APKBUILD
index dc4fb6a3f..d0363ad66 100644
--- a/user/kcompletion/APKBUILD
+++ b/user/kcompletion/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kcompletion
-pkgver=5.54.0
+pkgver=5.68.0
pkgrel=0
pkgdesc="Framework for implementing automatic completion of input"
url="https://www.kde.org/"
@@ -14,7 +14,6 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcompletion-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -26,19 +25,17 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_QCH:BOOL=ON \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
# All other tests require X11.
CTEST_OUTPUT_ON_FAILURE=TRUE ctest -R ksortablelisttest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="af813411090d25f85d1b409bd971d9f610cc7c1ce01463f70cf57791af9dafe88957d74be0b63c4ca8f7d2a790c48d34613a03bed03552cae30346576849f654 kcompletion-5.54.0.tar.xz"
+sha512sums="05c434549610404a8a9972fa88dd33245ec9b6e9b402a3602e2081b3ca3692127993307ceb56f8790b91d0a990a2241cf1258a54e316dedef1980b72741cb62e kcompletion-5.68.0.tar.xz"