summaryrefslogtreecommitdiff
path: root/user/kcoreaddons
diff options
context:
space:
mode:
Diffstat (limited to 'user/kcoreaddons')
-rw-r--r--user/kcoreaddons/APKBUILD14
-rw-r--r--user/kcoreaddons/utf8.patch17
2 files changed, 24 insertions, 7 deletions
diff --git a/user/kcoreaddons/APKBUILD b/user/kcoreaddons/APKBUILD
index a94b25c34..f6c1ce99e 100644
--- a/user/kcoreaddons/APKBUILD
+++ b/user/kcoreaddons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kcoreaddons
-pkgver=5.54.0
+pkgver=5.68.0
pkgrel=0
pkgdesc="Core KF5 framework"
url="https://www.kde.org/"
@@ -13,10 +13,11 @@ depends_dev="qt5-qtbase-dev"
makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev doxygen
shared-mime-info"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcoreaddons-$pkgver.tar.xz"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcoreaddons-$pkgver.tar.xz
+ utf8.patch
+ "
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -28,18 +29,17 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_QCH:BOOL=ON \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="8e4a2cd59a0ecdf09317e67aa20b96f37562035beb744d189856094bcb06944e175c78515374a8a090446e63c8174b2a949b744dff36f0e21c455a2cb5df5df9 kcoreaddons-5.54.0.tar.xz"
+sha512sums="a76e9f05d2a1fcec509f3a02ac6554b284ece1edf96e201c4f129826d16957fa1c1bd6c1f56debb10614c5222d794b094af1fee0d133a05d17ac9c18249cd1b8 kcoreaddons-5.68.0.tar.xz
+d462866912d9cc9a768477d872142eb67be6b616c044436a27aa71577546efe4aa323b3dac913f9dbb52fc62dbe27d464b30ac3c4cb23c5d7c414d96138e9300 utf8.patch"
diff --git a/user/kcoreaddons/utf8.patch b/user/kcoreaddons/utf8.patch
new file mode 100644
index 000000000..3fee25313
--- /dev/null
+++ b/user/kcoreaddons/utf8.patch
@@ -0,0 +1,17 @@
+Use UTF-8 for parsing /etc/os-release.
+
+diff --git a/src/lib/util/kosrelease.cpp b/src/lib/util/kosrelease.cpp
+index 0469aba..1d74f2a 100644
+--- a/src/lib/util/kosrelease.cpp
++++ b/src/lib/util/kosrelease.cpp
+@@ -134,9 +134,9 @@ public:
+ QStringList parts;
+ while (!file.atEnd()) {
+ // Trimmed to handle indented comment lines properly
+- line = QString::fromLatin1(file.readLine()).trimmed();
++ line = QString::fromUtf8(file.readLine()).trimmed();
+
+ if (line.startsWith(QLatin1Char('#'))) {
+ // Comment line
+ // Lines beginning with "#" shall be ignored as comments.
+ continue;