summaryrefslogtreecommitdiff
path: root/user/khotkeys/cmake-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/khotkeys/cmake-fixes.patch')
-rw-r--r--user/khotkeys/cmake-fixes.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/user/khotkeys/cmake-fixes.patch b/user/khotkeys/cmake-fixes.patch
new file mode 100644
index 000000000..6f6bfcc5d
--- /dev/null
+++ b/user/khotkeys/cmake-fixes.patch
@@ -0,0 +1,49 @@
+From ae5743738245437332b1bb670b9a3f8c429211e2 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Sun, 10 Feb 2019 20:26:25 +0100
+Subject: Harmonize usage of HAVE_X11, using #if and #cmakedefine01.
+
+---
+ CMakeLists.txt | 1 +
+ config-X11.h.cmake | 2 +-
+ libkhotkeysprivate/conditions/existing_window_condition.h | 1 -
+ 3 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2a96e3b..0955f4e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -37,6 +37,7 @@ find_package(LibKWorkspace CONFIG REQUIRED)
+ if(X11_FOUND)
+ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS X11Extras )
+ set(HAVE_XTEST ${X11_XTest_FOUND})
++ set(HAVE_X11 1)
+ endif()
+
+ configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h)
+diff --git a/config-X11.h.cmake b/config-X11.h.cmake
+index 60286dd..ae8978a 100644
+--- a/config-X11.h.cmake
++++ b/config-X11.h.cmake
+@@ -41,4 +41,4 @@
+ #cmakedefine HAS_RANDR_1_3 1
+
+ /* Define if you have X11 at all */
+-#define HAVE_X11 ${X11_FOUND}
+\ No newline at end of file
++#cmakedefine01 HAVE_X11
+diff --git a/libkhotkeysprivate/conditions/existing_window_condition.h b/libkhotkeysprivate/conditions/existing_window_condition.h
+index 92815eb..b6a4278 100644
+--- a/libkhotkeysprivate/conditions/existing_window_condition.h
++++ b/libkhotkeysprivate/conditions/existing_window_condition.h
+@@ -26,7 +26,6 @@
+
+ #include <KConfig> // Needed because of some Qt Status redefinitions
+ #include <KConfigGroup> // Needed because of some Qt Status redefinitions
+-#include <config-kwindowsystem.h> // Needed for HAVE_X11
+ #include <config-X11.h>
+ #include <kdemacros.h>
+
+--
+cgit v1.1
+