summaryrefslogtreecommitdiff
path: root/user/khotkeys
diff options
context:
space:
mode:
Diffstat (limited to 'user/khotkeys')
-rw-r--r--user/khotkeys/APKBUILD16
-rw-r--r--user/khotkeys/cmake-fixes.patch49
2 files changed, 6 insertions, 59 deletions
diff --git a/user/khotkeys/APKBUILD b/user/khotkeys/APKBUILD
index 0d53161a8..c171ad246 100644
--- a/user/khotkeys/APKBUILD
+++ b/user/khotkeys/APKBUILD
@@ -1,21 +1,18 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox-kde@adelielinux.org>
pkgname=khotkeys
-pkgver=5.12.8
+pkgver=5.18.3
pkgrel=0
pkgdesc="Hot key mapping for KDE Plasma 5"
url="https://www.KDE.org/"
arch="all"
license="LGPL-2.0+"
depends=""
-makedepends="cmake extra-cmake-modules qt5-qtbase-dev kcmutils-dev
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev kcmutils-dev libx11-dev
kdbusaddons-dev kdelibs4support-dev kglobalaccel-dev ki18n-dev kio-dev
- kxmlgui-dev libice-dev libx11-dev plasma-framework-dev
- plasma-workspace-dev"
+ kxmlgui-dev libice-dev libkworkspace-dev plasma-framework-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$pkgver.tar.xz
- cmake-fixes.patch
- "
+source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$pkgver.tar.xz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -28,7 +25,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
@@ -40,5 +37,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="df60c9d9be901cfeb6cc41e006015b98f373493362c10cf54bc479eb60a3d7ef33aca557497cdae32e351fd413a615620bbc04d53b42bd7ff7de458c36f8c170 khotkeys-5.12.8.tar.xz
-1c2558d8b142bc1de236e35b8f55a825f55d4c38c2b5cb2fbf02dcae1128325f45b15246f9c9d874d1afd2a4483df8501877121c6052b6d067892c5fbeca1dc5 cmake-fixes.patch"
+sha512sums="874f21eb10f6297c7defef6e646947afbfa8e07b695e734dffcfb36484ecec757f20e5cb1d7c080834d869c71d10d5ce64c9e05b6d5078ce3ed651a0989a2811 khotkeys-5.18.3.tar.xz"
diff --git a/user/khotkeys/cmake-fixes.patch b/user/khotkeys/cmake-fixes.patch
deleted file mode 100644
index 6f6bfcc5d..000000000
--- a/user/khotkeys/cmake-fixes.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From ae5743738245437332b1bb670b9a3f8c429211e2 Mon Sep 17 00:00:00 2001
-From: David Faure <faure@kde.org>
-Date: Sun, 10 Feb 2019 20:26:25 +0100
-Subject: Harmonize usage of HAVE_X11, using #if and #cmakedefine01.
-
----
- CMakeLists.txt | 1 +
- config-X11.h.cmake | 2 +-
- libkhotkeysprivate/conditions/existing_window_condition.h | 1 -
- 3 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2a96e3b..0955f4e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -37,6 +37,7 @@ find_package(LibKWorkspace CONFIG REQUIRED)
- if(X11_FOUND)
- find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS X11Extras )
- set(HAVE_XTEST ${X11_XTest_FOUND})
-+ set(HAVE_X11 1)
- endif()
-
- configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h)
-diff --git a/config-X11.h.cmake b/config-X11.h.cmake
-index 60286dd..ae8978a 100644
---- a/config-X11.h.cmake
-+++ b/config-X11.h.cmake
-@@ -41,4 +41,4 @@
- #cmakedefine HAS_RANDR_1_3 1
-
- /* Define if you have X11 at all */
--#define HAVE_X11 ${X11_FOUND}
-\ No newline at end of file
-+#cmakedefine01 HAVE_X11
-diff --git a/libkhotkeysprivate/conditions/existing_window_condition.h b/libkhotkeysprivate/conditions/existing_window_condition.h
-index 92815eb..b6a4278 100644
---- a/libkhotkeysprivate/conditions/existing_window_condition.h
-+++ b/libkhotkeysprivate/conditions/existing_window_condition.h
-@@ -26,7 +26,6 @@
-
- #include <KConfig> // Needed because of some Qt Status redefinitions
- #include <KConfigGroup> // Needed because of some Qt Status redefinitions
--#include <config-kwindowsystem.h> // Needed for HAVE_X11
- #include <config-X11.h>
- #include <kdemacros.h>
-
---
-cgit v1.1
-