summaryrefslogtreecommitdiff
path: root/user/kphotoalbum/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/kphotoalbum/APKBUILD')
-rw-r--r--user/kphotoalbum/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/user/kphotoalbum/APKBUILD b/user/kphotoalbum/APKBUILD
index e47058f3d..efb9b4586 100644
--- a/user/kphotoalbum/APKBUILD
+++ b/user/kphotoalbum/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kphotoalbum
-pkgver=5.5
-pkgrel=1
+pkgver=5.6.1
+pkgrel=0
pkgdesc="Versatile photo album software by KDE"
url="https://www.kphotoalbum.org/"
arch="all"
@@ -16,7 +16,6 @@ subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/kphotoalbum/$pkgver/kphotoalbum-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -27,18 +26,16 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="fcca891a94580db2f606c5d077af2651e1dbcd59429823410f9fd2d07ac0c3c625ac441b723d4c8cb3ac7ede26ccf69f955c19fe302fffc9788fc33def9ee3e0 kphotoalbum-5.5.tar.xz"
+sha512sums="fa1f4d566cd99e8c434b6e1fe28d8910b3b9c6aa05947ffbfa1b2b8efdab76f243f4b12883586e0c6692bfe54763a285374e16f3ceb23051619fe9b84cd58ea7 kphotoalbum-5.6.1.tar.xz"