summaryrefslogtreecommitdiff
path: root/user/kpimtextedit/qt5.9.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/kpimtextedit/qt5.9.patch')
-rw-r--r--user/kpimtextedit/qt5.9.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/user/kpimtextedit/qt5.9.patch b/user/kpimtextedit/qt5.9.patch
new file mode 100644
index 000000000..50c29e0e0
--- /dev/null
+++ b/user/kpimtextedit/qt5.9.patch
@@ -0,0 +1,49 @@
+From 6961b54d1c814f2e7aafd7db8256f82688f014a3 Mon Sep 17 00:00:00 2001
+Date: Mon, 17 Dec 2018 07:23:52 +0100
+Subject: Revert "Remove QT_CHECK"
+
+---
+ .../plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp b/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
+index 8ce0fe9..c07699c 100644
+--- a/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
++++ b/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
+@@ -144,9 +144,13 @@ void PlainTextSyntaxSpellCheckingHighlighter::highlightBlock(const QString &text
+
+ const auto nextBlock = currentBlock().next();
+ if (nextBlock.isValid()) {
++#if QT_VERSION >= QT_VERSION_CHECK(5, 10, 0)
+ QMetaObject::invokeMethod(this, [this, nextBlock] {
+ rehighlightBlock(nextBlock);
+ }, Qt::QueuedConnection);
++#else
++ QMetaObject::invokeMethod(this, "rehighlightBlock", Qt::QueuedConnection, Q_ARG(QTextBlock, nextBlock));
++#endif
+ }
+ }
+
+--
+cgit v1.1
+
+--- kpimtextedit-19.04.0/CMakeLists.txt.old 2019-04-12 00:14:22.000000000 +0000
++++ kpimtextedit-19.04.0/CMakeLists.txt 2019-04-19 06:21:56.055556133 +0000
+@@ -4,7 +4,7 @@
+ project(KPimTextEdit VERSION ${PIM_VERSION})
+
+ # ECM setup
+-set(KF5_MIN_VERSION "5.56.0")
++set(KF5_MIN_VERSION "5.54.0")
+
+ find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
+ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
+@@ -36,7 +36,7 @@
+ SOVERSION 5
+ )
+
+-set(QT_REQUIRED_VERSION "5.10.0")
++set(QT_REQUIRED_VERSION "5.9.0")
+ find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED COMPONENTS Widgets)
+ find_package(Grantlee5 "5.1" CONFIG REQUIRED)
+ set_package_properties(Grantlee5 PROPERTIES