summaryrefslogtreecommitdiff
path: root/user/ksysguard
diff options
context:
space:
mode:
Diffstat (limited to 'user/ksysguard')
-rw-r--r--user/ksysguard/0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch31
-rw-r--r--user/ksysguard/APKBUILD10
-rw-r--r--user/ksysguard/ksysguard-5.6.5-rindex-header.patch2
3 files changed, 5 insertions, 38 deletions
diff --git a/user/ksysguard/0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch b/user/ksysguard/0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch
deleted file mode 100644
index 8828736f3..000000000
--- a/user/ksysguard/0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From d6fa7c0ab6c3a6b1494ffd12b93ee5cc2e4d3d5c Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Mon, 18 Mar 2019 14:34:26 -0500
-Subject: [PATCH] Linux softraid: define _GNU_SOURCE for pipe2
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-In a strict POSIX compilation environment, pipe2 is not defined. Use
-the _GNU_SOURCE FTM to expose it.
-
-Fixes a failure to build ksysguard on Adélie Linux.
----
- ksysguardd/Linux/softraid.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/ksysguardd/Linux/softraid.c b/ksysguardd/Linux/softraid.c
-index c2123fb7..96eb373e 100644
---- a/ksysguardd/Linux/softraid.c
-+++ b/ksysguardd/Linux/softraid.c
-@@ -27,6 +27,7 @@
- #include <sys/types.h> /* for open */
- #include <sys/stat.h> /* for open */
- #include <fcntl.h> /* for open */
-+#define _GNU_SOURCE /* pipe2 */
- #include <unistd.h> /* for read, close, exec, fork */
- #include <stdlib.h> /* for exit */
- #include <sys/wait.h> /* for wait :) */
---
-2.19.2
-
diff --git a/user/ksysguard/APKBUILD b/user/ksysguard/APKBUILD
index 54c227779..894fd3810 100644
--- a/user/ksysguard/APKBUILD
+++ b/user/ksysguard/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox-kde@adelielinux.org>
pkgname=ksysguard
-pkgver=5.12.8
+pkgver=5.18.3
pkgrel=0
pkgdesc="KDE system monitor utility"
url="https://www.kde.org/"
@@ -15,7 +15,6 @@ makedepends="qt5-qtbase-dev kconfig-dev kcoreaddons-dev kdbusaddons-dev kio-dev
subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/plasma/$pkgver/ksysguard-$pkgver.tar.xz
ksysguard-5.6.5-rindex-header.patch
- 0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch
"
build() {
@@ -29,7 +28,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
@@ -41,6 +40,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="9ea21ba61866f1b36f15f41011dfcab562ede45cc3403f030184680f6e3b0717fc5ac774089784a3d14015728c3b721887083154b32b786e804dfc1aace89585 ksysguard-5.12.8.tar.xz
-13a26451c459cff1d3b00af27c953d10c55e7e8f43ef7a6f0f54dd05dcb612546545c0170089e9499bb041f004cdacf19cb112d247a8ccf8fd4e77fea0d1c8bc ksysguard-5.6.5-rindex-header.patch
-0a424bb5e23f283d0cccfe86c0a6c2915f563a82e27a1dc16be8b4dc4b3d90ce116c4eb448dd1d5dc07602225468880206a5eb70c1b66d1e19e9a405fae7aa88 0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch"
+sha512sums="db4c9f9ebe17621fad0326504bab88928d417f58bdf6fff2644eb1c446be1c2d2386a4668029905e79021d3c2bb2ba450e686356094ab9af024d892584498993 ksysguard-5.18.3.tar.xz
+75e07b80c647bc6fdfb092ad3855813ef6bfe91b0ad03562dacfe4e680cfdee201364a2e452db162822045684635c1791ab2392c47d8e5c560c9e617a970cf39 ksysguard-5.6.5-rindex-header.patch"
diff --git a/user/ksysguard/ksysguard-5.6.5-rindex-header.patch b/user/ksysguard/ksysguard-5.6.5-rindex-header.patch
index 423da608c..7b900d751 100644
--- a/user/ksysguard/ksysguard-5.6.5-rindex-header.patch
+++ b/user/ksysguard/ksysguard-5.6.5-rindex-header.patch
@@ -1,6 +1,6 @@
--- ksysguard-5.6.5/ksysguardd/Linux/diskstat.c.old 2016-06-14 11:09:02.000000000 +0100
+++ ksysguard-5.6.5/ksysguardd/Linux/diskstat.c 2016-08-07 02:51:53.101362572 +0100
-@@ -24,6 +24,7 @@
+@@ -26,6 +26,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>