summaryrefslogtreecommitdiff
path: root/user/libfm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libfm/APKBUILD')
-rw-r--r--user/libfm/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/user/libfm/APKBUILD b/user/libfm/APKBUILD
index ad75ec5d9..a32925320 100644
--- a/user/libfm/APKBUILD
+++ b/user/libfm/APKBUILD
@@ -7,6 +7,8 @@ pkgdesc="Library for file management"
url="https://wiki.lxde.org/en/PCManFM"
arch="all"
license="GPL-2.0+"
+depends=""
+depends_dev="libfm-extra-dev"
makedepends="dbus-glib-dev glib-dev gtk+2.0-dev intltool libexif-dev
libfm-extra-dev menu-cache-dev udisks2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -15,7 +17,6 @@ source="https://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.xz
"
build() {
- cd "$builddir"
mv data/libfm.conf data/libfm.conf.sample
./configure \
--prefix=/usr \
@@ -26,13 +27,14 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
+ # this symlink breaks installation with -extra-dev,
+ # and extra is always required anyway
+ rm "$pkgdir"/usr/include/libfm
}
sha512sums="f385cf7bf2f4800c11dd6474cd20009cbe1208f1d08570b61954ea8bd84c56cc49880cbf84d4b2aa4b91eb6929d017ebc427649391059b786d7e6fc4535e4f14 libfm-1.3.1.tar.xz