summaryrefslogtreecommitdiff
path: root/user/libpng/libpng-fix-arm-neon.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/libpng/libpng-fix-arm-neon.patch')
-rw-r--r--user/libpng/libpng-fix-arm-neon.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/libpng/libpng-fix-arm-neon.patch b/user/libpng/libpng-fix-arm-neon.patch
new file mode 100644
index 000000000..2cd3f18c2
--- /dev/null
+++ b/user/libpng/libpng-fix-arm-neon.patch
@@ -0,0 +1,35 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -364,17 +364,21 @@
+ [case "$enableval" in
+ no|off)
+ # disable the default enabling on __ARM_NEON__ systems:
++ AC_DEFINE([PNG_ARM_NEON], [], [ARM NEON support])
+ AC_DEFINE([PNG_ARM_NEON_OPT], [0],
+ [Disable ARM Neon optimizations])
+ # Prevent inclusion of the assembler files below:
+ enable_arm_neon=no;;
+ check)
++ AC_DEFINE([PNG_ARM_NEON], [], [ARM NEON support])
+ AC_DEFINE([PNG_ARM_NEON_CHECK_SUPPORTED], [],
+ [Check for ARM Neon support at run-time]);;
+ api)
++ AC_DEFINE([PNG_ARM_NEON], [], [ARM NEON support])
+ AC_DEFINE([PNG_ARM_NEON_API_SUPPORTED], [],
+ [Turn on ARM Neon optimizations at run-time]);;
+ yes|on)
++ AC_DEFINE([PNG_ARM_NEON], [], [ARM NEON support])
+ AC_DEFINE([PNG_ARM_NEON_OPT], [2],
+ [Enable ARM Neon optimizations])
+ AC_MSG_WARN([--enable-arm-neon: please specify 'check' or 'api', if]
+--- a/pngpriv.h
++++ b/pngpriv.h
+@@ -127,7 +127,7 @@
+ * associated assembler code, pass --enable-arm-neon=no to configure
+ * or put -DPNG_ARM_NEON_OPT=0 in CPPFLAGS.
+ */
+-# if (defined(__ARM_NEON__) || defined(__ARM_NEON)) && \
++# if defined(PNG_ARM_NEON) && (defined(__ARM_NEON__) || defined(__ARM_NEON)) && \
+ defined(PNG_ALIGNED_MEMORY_SUPPORTED)
+ # define PNG_ARM_NEON_OPT 2
+ # else