summaryrefslogtreecommitdiff
path: root/user/libtommath/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libtommath/APKBUILD')
-rw-r--r--user/libtommath/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/user/libtommath/APKBUILD b/user/libtommath/APKBUILD
new file mode 100644
index 000000000..41e3a1ea1
--- /dev/null
+++ b/user/libtommath/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libtommath
+pkgver=1.1.0_rc1
+pkgrel=0
+pkgdesc="Theoretic multiple-precision integer library"
+url="https://www.libtom.net/LibTomMath/"
+arch="all"
+license="Unlicense"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="https://github.com/libtom/libtommath/releases/download/v${pkgver/_/-}/ltm-${pkgver/_/-}.tar.xz"
+builddir="$srcdir/$pkgname-${pkgver/_/-}"
+
+build() {
+ cd "$builddir"
+ make PREFIX=/usr -f makefile.shared
+}
+
+check() {
+ cd "$builddir"
+ make PREFIX=/usr -f makefile.shared test_standalone
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" -f makefile.shared install
+}
+
+sha512sums="4cee5d59cd2eaf14591ee280dcdcdd5915f38584b7259b5752e7316cd1a9966f1c969ee3b64d136ae7044c5834cfc8c781db300ede503ec2e657083de3692fd2 ltm-1.1.0-rc1.tar.xz"