summaryrefslogtreecommitdiff
path: root/user/libutempter/fix-linking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/libutempter/fix-linking.patch')
-rw-r--r--user/libutempter/fix-linking.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/user/libutempter/fix-linking.patch b/user/libutempter/fix-linking.patch
new file mode 100644
index 000000000..91719507a
--- /dev/null
+++ b/user/libutempter/fix-linking.patch
@@ -0,0 +1,11 @@
+--- libutempter-1.1.6/Makefile.old 2010-11-04 17:14:53.000000000 +0000
++++ libutempter-1.1.6/Makefile 2018-08-29 14:47:24.740000000 +0000
+@@ -52,7 +52,7 @@
+ $(COMPILE.c) -fPIC $< $(OUTPUT_OPTION)
+
+ $(PROJECT): utempter.c
+- $(LINK.c) -Wl,-z,now,-stats $(LDLIBS) $< $(OUTPUT_OPTION)
++ $(LINK.c) -Wl,-z,now,-stats $< $(OUTPUT_OPTION) $(LDLIBS)
+
+ $(SHAREDLIB): iface.os $(MAP)
+ $(LINK.o) -shared \