summaryrefslogtreecommitdiff
path: root/user/lsof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/lsof/APKBUILD')
-rw-r--r--user/lsof/APKBUILD40
1 files changed, 14 insertions, 26 deletions
diff --git a/user/lsof/APKBUILD b/user/lsof/APKBUILD
index 370d8c7a7..5330d1a7a 100644
--- a/user/lsof/APKBUILD
+++ b/user/lsof/APKBUILD
@@ -1,30 +1,24 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=lsof
-pkgver=4.91
+pkgver=4.93.2
pkgrel=0
pkgdesc="LiSt Open Files"
url="https://people.freebsd.org/~abe"
arch="all"
license="zlib-acknowledgement"
-subpackages="$pkgname-doc"
+depends=""
makedepends="linux-headers cmd:which utmps-dev"
-source="http://www.mirrorservice.org/sites/lsof.itap.purdue.edu/pub/tools/unix/lsof/${pkgname}_${pkgver}.tar.gz
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lsof-org/lsof/archive/$pkgver.tar.gz
utmps.patch
+ test-disable-nfs-test.patch
test-enable-suite.patch
test-linux-sysmacros.patch
- test-disable-nfs-test.patch"
-builddir="$srcdir/${pkgname}_${pkgver}"
-
-unpack() {
- default_unpack
- cd "$builddir"
- tar xf "${pkgname}_${pkgver}_src.tar"
-}
+ "
prepare() {
default_prepare
- cd "$builddir/${pkgname}_${pkgver}_src"
sed -i "s|/\* #define\tHASSECURITY\t1 \*/|#define\tHASSECURITY\t1|" \
dialects/linux/machine.h
@@ -32,32 +26,26 @@ prepare() {
}
build () {
- cd "$builddir/${pkgname}_${pkgver}_src"
-
./Configure -n linux
make
}
check() {
- cd "$builddir/${pkgname}_${pkgver}_src/tests"
-
# The LTsock test will fail if /etc/hosts is not set correctly.
# Make sure that 127.0.0.1 and ::1 have aliases corresponding to
# `hostname`.
- printf "y" | make
- make opt
+ printf "y" | make -C tests
+ make -C tests opt
}
package() {
- cd "$builddir/${pkgname}_${pkgver}_src"
-
install -Dm755 lsof "$pkgdir/usr/bin/lsof"
- install -Dm644 lsof.8 "$pkgdir/usr/share/man/man8/lsof.8"
+ install -Dm644 Lsof.8 "$pkgdir/usr/share/man/man8/lsof.8"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/lsof/COPYING"
}
-sha512sums="95937afda1ba58e6636b2a2661d819480ec42b4beafc0e69e6132d7fdffd4e3974a95036a02c6fd8baf92089c73ac969cdc00a297bf0249257867d695bff2f94 lsof_4.91.tar.gz
-dfbfcfd41a4bccf3335ed01cc2dc9a11b6badd3149878d89ef5fed322a914d3d8341c68783140a4973d007907ce54b4438f011c26289df9e27d2d487a8f6b0b0 utmps.patch
-34d9573f90d942c717e3f3ff17283a66981c4a2e8e886746b591f980142d66115bc7afe6bdd0fc660ea6c1b42f591b161b9535e5849b8757e79546c197ccfdda test-linux-sysmacros.patch
-7f3e9b2850af54a5391db6a8f7eaa22329217fd559d3d41ee3bcd33b07b3526d17da75a542d28b013111bc5d5712a718e961aa4fe84ca3c5e73a97e0518ba2ec test-enable-suite.patch
-d299e2070415168f75a9ee6424e18c1496f6d1fd5430b13a92159422c9df58050ac63e22cebd13a5228207f5960cf2cde5830a46c9ec7a4c216f5e6fb71887f4 test-disable-nfs-test.patch"
+sha512sums="3c4a4d503391b1a648a08a4947c2e72a9629b169eddf50738b16a16a82f2a26967e4db2902e4a9157de5a73ae638db48e392117ffbd591e9fafd6b1725cd01a0 lsof-4.93.2.tar.gz
+d6f2f5b991c137abf30b8cd29eebaf7662f7255e6d99b7fba5c945eba09a2c7ce7c444895e72c6871a7d90fe3ad8ca28b052a428127ba0342b13b3b027a3c77f utmps.patch
+f2128d3aa3183244ade8a553f5a1ca7a5db571eae4ebd9c87c05f4b2996de152796573dd35d9c57d0f35671f2eb928b66fe637b1693ec1b8828c9a8d739c6771 test-disable-nfs-test.patch
+72923d42db63435a95b07d17b6c6e8ac64f1a8f20505f851ed706783078bce0c49cac61dd8c05c08d24333c07ad981aaf34d4a4e4d1edb2a82ae8c9e9b8328e0 test-enable-suite.patch
+14473839fa695e84cddac8bc1a33e06aba082bcc56baa6c4a6134a6c55ec1c9d08f756dab483785c0796a9442345853f7762fed76efb60a732fbc709bb06d25f test-linux-sysmacros.patch"