summaryrefslogtreecommitdiff
path: root/user/lsof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/lsof/APKBUILD')
-rw-r--r--user/lsof/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/user/lsof/APKBUILD b/user/lsof/APKBUILD
index 5330d1a7a..abf4075b5 100644
--- a/user/lsof/APKBUILD
+++ b/user/lsof/APKBUILD
@@ -34,7 +34,9 @@ check() {
# The LTsock test will fail if /etc/hosts is not set correctly.
# Make sure that 127.0.0.1 and ::1 have aliases corresponding to
# `hostname`.
- printf "y" | make -C tests
+ sed -i tests/CkTestDB \
+ -e 's/^# This dialect may never have been validated.*$/exit 0/'
+ make -C tests
make -C tests opt
}